Bug 1814005 - blivet.errors.DeviceFormatError: device is active
Summary: blivet.errors.DeviceFormatError: device is active
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: 31
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vojtech Trefny
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:c44e28293fbbfa79cf14de44538...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-16 18:03 UTC by Giacomo Longo
Modified: 2020-08-21 12:17 UTC (History)
12 users (show)

Fixed In Version: python-blivet-3.3.0-1.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-21 12:17:23 UTC
Type: ---


Attachments (Terms of Use)
File: anaconda-tb (1.66 MB, text/plain)
2020-03-16 18:03 UTC, Giacomo Longo
no flags Details
File: anaconda.log (135.27 KB, text/plain)
2020-03-16 18:03 UTC, Giacomo Longo
no flags Details
File: blivet-gui-utils.log (27.26 KB, text/plain)
2020-03-16 18:03 UTC, Giacomo Longo
no flags Details
File: dbus.log (2.92 KB, text/plain)
2020-03-16 18:03 UTC, Giacomo Longo
no flags Details
File: environ (637 bytes, text/plain)
2020-03-16 18:03 UTC, Giacomo Longo
no flags Details
File: lorax-packages.log (25.47 KB, text/plain)
2020-03-16 18:03 UTC, Giacomo Longo
no flags Details
File: lsblk_output (2.98 KB, text/plain)
2020-03-16 18:03 UTC, Giacomo Longo
no flags Details
File: nmcli_dev_list (1.69 KB, text/plain)
2020-03-16 18:04 UTC, Giacomo Longo
no flags Details
File: os_info (691 bytes, text/plain)
2020-03-16 18:04 UTC, Giacomo Longo
no flags Details
File: program.log (52.92 KB, text/plain)
2020-03-16 18:04 UTC, Giacomo Longo
no flags Details
File: storage.log (744.47 KB, text/plain)
2020-03-16 18:04 UTC, Giacomo Longo
no flags Details
File: syslog (343.99 KB, text/plain)
2020-03-16 18:04 UTC, Giacomo Longo
no flags Details
File: packaging.log (15.43 KB, text/plain)
2020-03-16 18:04 UTC, Giacomo Longo
no flags Details

Description Giacomo Longo 2020-03-16 18:03:41 UTC
Description of problem:
I did custom partitioning and it gave this error

Version-Release number of selected component:
anaconda-31.22.6

The following was filed automatically by anaconda:
anaconda 31.22.6 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.7/site-packages/blivet/formats/__init__.py", line 558, in _pre_destroy
    raise DeviceFormatError("device is active")
  File "/usr/lib/python3.7/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.7/site-packages/blivet/formats/__init__.py", line 548, in destroy
    self._pre_destroy(**kwargs)
  File "/usr/lib/python3.7/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.7/site-packages/blivet/deviceaction.py", line 723, in execute
    self.format.destroy()
  File "/usr/lib/python3.7/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.7/site-packages/blivet/actionlist.py", line 327, in process
    action.execute(callbacks)
  File "/usr/lib/python3.7/site-packages/blivet/actionlist.py", line 48, in wrapped_func
    return func(obj, *args, **kwargs)
  File "/usr/lib/python3.7/site-packages/blivet/blivet.py", line 106, in do_it
    self.devicetree.actions.process(callbacks=callbacks, devices=self.devices)
  File "/usr/lib/python3.7/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib64/python3.7/site-packages/pyanaconda/storage/installation.py", line 50, in turn_on_filesystems
    storage.do_it(callbacks)
  File "/usr/lib64/python3.7/site-packages/pyanaconda/installation_tasks.py", line 450, in run_task
    self._task(*self._task_args, **self._task_kwargs)
  File "/usr/lib64/python3.7/site-packages/pyanaconda/installation_tasks.py", line 484, in start
    self.run_task()
  File "/usr/lib64/python3.7/site-packages/pyanaconda/installation_tasks.py", line 305, in start
    item.start()
  File "/usr/lib64/python3.7/site-packages/pyanaconda/installation_tasks.py", line 305, in start
    item.start()
  File "/usr/lib64/python3.7/site-packages/pyanaconda/installation_tasks.py", line 305, in start
    item.start()
  File "/usr/lib64/python3.7/site-packages/pyanaconda/installation.py", line 394, in run_installation
    queue.start()
  File "/usr/lib64/python3.7/threading.py", line 870, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.7/site-packages/pyanaconda/threading.py", line 280, in run
    threading.Thread.run(self)
blivet.errors.DeviceFormatError: device is active

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-S-dvd-x86_64-31 rd.live.check quiet
dnf.librepo.log: 
executable:     /sbin/anaconda
hashmarkername: anaconda
hawkey.log:     INFO mar-16 17:51:23 === Started libdnf-0.35.3 ===
kernel:         5.3.7-301.fc31.x86_64
product:        Fedora
release:        Fedora release 31 (Thirty One)
type:           anaconda
version:        31

Comment 1 Giacomo Longo 2020-03-16 18:03:47 UTC
Created attachment 1670620 [details]
File: anaconda-tb

Comment 2 Giacomo Longo 2020-03-16 18:03:50 UTC
Created attachment 1670621 [details]
File: anaconda.log

Comment 3 Giacomo Longo 2020-03-16 18:03:52 UTC
Created attachment 1670622 [details]
File: blivet-gui-utils.log

Comment 4 Giacomo Longo 2020-03-16 18:03:54 UTC
Created attachment 1670623 [details]
File: dbus.log

Comment 5 Giacomo Longo 2020-03-16 18:03:55 UTC
Created attachment 1670624 [details]
File: environ

Comment 6 Giacomo Longo 2020-03-16 18:03:57 UTC
Created attachment 1670625 [details]
File: lorax-packages.log

Comment 7 Giacomo Longo 2020-03-16 18:03:59 UTC
Created attachment 1670626 [details]
File: lsblk_output

Comment 8 Giacomo Longo 2020-03-16 18:04:00 UTC
Created attachment 1670627 [details]
File: nmcli_dev_list

Comment 9 Giacomo Longo 2020-03-16 18:04:02 UTC
Created attachment 1670628 [details]
File: os_info

Comment 10 Giacomo Longo 2020-03-16 18:04:04 UTC
Created attachment 1670629 [details]
File: program.log

Comment 11 Giacomo Longo 2020-03-16 18:04:08 UTC
Created attachment 1670630 [details]
File: storage.log

Comment 12 Giacomo Longo 2020-03-16 18:04:11 UTC
Created attachment 1670631 [details]
File: syslog

Comment 13 Giacomo Longo 2020-03-16 18:04:13 UTC
Created attachment 1670632 [details]
File: packaging.log

Comment 14 Vendula Poncova 2020-03-17 12:26:57 UTC
It seems to be an issue in the storage configuration library. Reassigning to blivet.

Comment 15 Vojtech Trefny 2020-03-25 08:59:27 UTC
Thank you for the report. The problem is caused by the DM integrity device on your md127 RAID array, as a workaround please remove the device manually before starting the installation.

Comment 16 Vojtech Trefny 2020-07-23 08:32:11 UTC
upstream PR: https://github.com/storaged-project/blivet/pull/855


Note You need to log in before you can comment on or make changes to this bug.