Bug 1814180 - VM Dashboard in Kibana portal does not show three plugins .
Summary: VM Dashboard in Kibana portal does not show three plugins .
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-metrics
Version: 4.3.8
Hardware: All
OS: All
high
medium
Target Milestone: ---
: ---
Assignee: Nobody
QA Contact: Lucie Leistnerova
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-17 09:45 UTC by Gajanan
Modified: 2020-08-03 15:37 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-14 10:27:34 UTC
oVirt Team: Metrics
Target Upstream Version:
lsvaty: testing_plan_complete-


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 4927981 0 None None None 2020-03-25 12:16:08 UTC
Red Hat Knowledge Base (Solution) 5161761 0 None None None 2020-06-16 16:36:31 UTC

Description Gajanan 2020-03-17 09:45:23 UTC
Description of problem:

VM Dashboard in Kibana portal does not show three plugins . 

The below message is seen for three plugins:

"could not locate index-pattern-field(id:collectd.virt.percent)" 
 
How reproducible:

Install the RHV Metric store freshly on RHV-M 4.3.8-2 version

Actual results:

VM dashboard does not show three plugins statistics. 


Expected results:

VM dashboard should show the three plugins statistics. 

Additional info:

See the private screenshot file attached to the bug.

Comment 2 Gajanan 2020-03-25 12:02:07 UTC
Hello Shirly,

I have a customer asking for workaround for this issue, is it possible ?

Comment 15 Sandro Bonazzola 2020-07-14 10:27:34 UTC
We are dropping the metrics solution we had in 4.3 in favor of the new one based on Grafana + DWH in 4.4.
Closing this due to capacity and obsolescence of the existing solution.

Comment 16 Shirly Radco 2020-07-14 12:21:26 UTC
Please have a look at your environment. This issue was fixed after I did this:
1. Go to Management -> Index Patterns
2. Go to the "project.*" index
3. Press on the refresh button(On the right side next to the remove index button and to the star button)

These steps are part of the documentation...
The customer probably did not refresh the index.

I would also recommend to set this as the default index by pressing on the start button.
This way they will get this index as the first index they see when they log in.

Comment 17 Gajanan 2020-07-16 09:42:03 UTC
(In reply to Shirly Radco from comment #16)
> Please have a look at your environment. This issue was fixed after I did
> this:
> 1. Go to Management -> Index Patterns
> 2. Go to the "project.*" index
> 3. Press on the refresh button(On the right side next to the remove index
> button and to the star button)
> 
> These steps are part of the documentation...
> The customer probably did not refresh the index.
> 
> I would also recommend to set this as the default index by pressing on the
> start button.
> This way they will get this index as the first index they see when they log
> in.

Thanks for these steps shirly.  

Today for another customer we re-imported the dashboard-examples all three files and the issue was not seen.  

For this customer, I refreshed the indexes it did not work, so i deleted all three dashboards,searches, visualizations and re imported it, then refreshed the indexes, it worked.

All plugins show the statistics now. 

He also has another environment, i will ask him to try these steps on it.


Note You need to log in before you can comment on or make changes to this bug.