Bug 181435 - problems setting up grub bootloader from rescue cd/recue mode
problems setting up grub bootloader from rescue cd/recue mode
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
5
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Peter Jones
Mike McLean
:
: 181436 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-13 17:56 EST by Juergen Bullinger
Modified: 2008-03-10 20:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 20:24:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juergen Bullinger 2006-02-13 17:56:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; de-DE; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I had problem setting up the bootloader after I screwed up my bootloader configuration. I seem to be talented in screwing bootloaders up :o)

I guess the probem are the different "symbolic names" used for the devices e.g. /dev/sda1 and /dev/happer/ebadjjisomething1

It seems that the regular installer uses /dev/sda1, but if you try to reinstall the bootloader using a rescue cd it doesn't recognize the name /dev/sda1. It says that this device is not a supported bios device.
I could resolve the problem by changeing the /boot/grub/device.map file on my partition from which i install the bootloader. I replaced /dev/sda1 by the indian name er I mean by /dev/badjji..... Then it worked.

I think this is not really a problem specific to FC5. I already had similar problems on FC4. I can not tell you how many times I reinstalled linux in plain desperation, because I didn't know how to reinstall the bootloader because of problems like the one mentioned above. I also tried to use the update function of the installation cds of FC4 on the existing FC4 installation and was happy when I was asked if the bootloader should be installed, but after doing all the steps of installation the setup function just said, that the bootloader was not installed, because there were no kernel? or base? packages to install.

Maybe the problem is caused by my parallel installations of linux.



Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Install several parallel linux partitions
2. try to update the bootloader using grub-install
3.
  

Actual Results:  Sometimes the update does not work.
If the bootloader encounters a problem it should just undo it's changes. Maybe by creating a backup of the MBR or whatever.


Expected Results:  SUGGESTIONS: 
1. to me it seems that the installation makes no suggestions on how to install the bootloader if you have parallel installations. I think the process of installing the bootloader should be guided.
The most error tolerant way of installing the bootloader would probably be to install it on both the MBR and the partition itself, but in the installation process you can not choose that the bootloader should be installed on both you have to choose either/or. Maybe it would be better to seperate the installation of grub. If the user choses to install it on the MBR, the MBR-Installation should only be a chainloader-installation which chainloads the grub-bootloader on the Fedora partition.

2. grub-install should check if the bootloader installation would work or not and if it doesn't it should ask the user if it should undo the change by writing back the previous value of the sector where the bootloader is installed.

3. the installation of the bootloader from a rescue disc should be much easier. I don't think a user without experience would ever be able to recover a crashed bootloader config.


Additional info:

Please not there are some different points described in this message, but all of them are about usability of bootloader installations.
Comment 1 Frank Arnold 2006-02-14 00:01:25 EST
*** Bug 181436 has been marked as a duplicate of this bug. ***
Comment 2 Rahul Sundaram 2006-02-20 05:49:46 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 3 Juergen Bullinger 2006-03-05 13:33:26 EST
Please be so kind as to read my explanations. Why do I test fedora and write
lenghtly reports with proposals if you don't read them?
The bootloader config is a critical point and unfortunately also in FC5 Test 3
not optimal. It is very easy to screw it up but very hard to recover it, because
it seems not to be possible to to recover it from a rescue cd without very deep
knowlege of grub and the devicemapper-hell. 
Comment 4 Matthew Miller 2007-04-06 12:40:53 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 5 petrosyan 2008-03-10 20:24:47 EDT
The information we've requested above is required in order
to review this problem report further and diagnose/fix the
issue if it is still present.  Since there have not been any
updates to the report since thirty (30) days or more since we
requested additional information, we're assuming the problem
is either no longer present in the current Fedora release, or
that there is no longer any interest in tracking the problem.

Setting status to "INSUFFICIENT_DATA".  If you still
experience this problem after updating to our latest Fedora
release and can provide the information previously requested, 
please feel free to reopen the bug report.

Thank you in advance.

Note You need to log in before you can comment on or make changes to this bug.