Bug 181436 - problems setting up grub bootloader from rescue cd/recue mode
problems setting up grub bootloader from rescue cd/recue mode
Status: CLOSED DUPLICATE of bug 181435
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
5
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Peter Jones
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-13 17:58 EST by Juergen Bullinger
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-14 00:01:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juergen Bullinger 2006-02-13 17:58:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; de-DE; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I had problem setting up the bootloader after I screwed up my bootloader configuration. I seem to be talented in screwing bootloaders up :o)

I guess the probem are the different "symbolic names" used for the devices e.g. /dev/sda1 and /dev/happer/ebadjjisomething1

It seems that the regular installer uses /dev/sda1, but if you try to reinstall the bootloader using a rescue cd it doesn't recognize the name /dev/sda1. It says that this device is not a supported bios device.
I could resolve the problem by changeing the /boot/grub/device.map file on my partition from which i install the bootloader. I replaced /dev/sda1 by the indian name er I mean by /dev/badjji..... Then it worked.

I think this is not really a problem specific to FC5. I already had similar problems on FC4. I can not tell you how many times I reinstalled linux in plain desperation, because I didn't know how to reinstall the bootloader because of problems like the one mentioned above. I also tried to use the update function of the installation cds of FC4 on the existing FC4 installation and was happy when I was asked if the bootloader should be installed, but after doing all the steps of installation the setup function just said, that the bootloader was not installed, because there were no kernel? or base? packages to install.

Maybe the problem is caused by my parallel installations of linux.



Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Install several parallel linux partitions
2. try to update the bootloader using grub-install
3.
  

Actual Results:  Sometimes the update does not work.
If the bootloader encounters a problem it should just undo it's changes. Maybe by creating a backup of the MBR or whatever.


Expected Results:  SUGGESTIONS: 
1. to me it seems that the installation makes no suggestions on how to install the bootloader if you have parallel installations. I think the process of installing the bootloader should be guided.
The most error tolerant way of installing the bootloader would probably be to install it on both the MBR and the partition itself, but in the installation process you can not choose that the bootloader should be installed on both you have to choose either/or. Maybe it would be better to seperate the installation of grub. If the user choses to install it on the MBR, the MBR-Installation should only be a chainloader-installation which chainloads the grub-bootloader on the Fedora partition.

2. grub-install should check if the bootloader installation would work or not and if it doesn't it should ask the user if it should undo the change by writing back the previous value of the sector where the bootloader is installed.

3. the installation of the bootloader from a rescue disc should be much easier. I don't think a user without experience would ever be able to recover a crashed bootloader config.


Additional info:

Please not there are some different points described in this message, but all of them are about usability of bootloader installations.
Comment 1 Frank Arnold 2006-02-14 00:01:17 EST

*** This bug has been marked as a duplicate of 181435 ***

Note You need to log in before you can comment on or make changes to this bug.