Bug 1814406 - [abrt] gnome-tweaks: _execute_child(): subprocess.py:1702:_execute_child:FileNotFoundError: [Errno 2] Datei oder Verzeichnis nicht gefunden: 'gnome-shell-extension-prefs'
Summary: [abrt] gnome-tweaks: _execute_child(): subprocess.py:1702:_execute_child:File...
Keywords:
Status: CLOSED DUPLICATE of bug 1812779
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-tweaks
Version: 32
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mohamed El Morabity
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:a255e470c8f4c5fb2964927f4bb...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-17 19:32 UTC by Peter
Modified: 2020-03-19 20:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-19 20:44:14 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (2.20 KB, text/plain)
2020-03-17 19:32 UTC, Peter
no flags Details
File: cpuinfo (2.33 KB, text/plain)
2020-03-17 19:32 UTC, Peter
no flags Details
File: environ (1.77 KB, text/plain)
2020-03-17 19:32 UTC, Peter
no flags Details
File: mountinfo (2.65 KB, text/plain)
2020-03-17 19:32 UTC, Peter
no flags Details
File: namespaces (129 bytes, text/plain)
2020-03-17 19:32 UTC, Peter
no flags Details
File: open_fds (2.05 KB, text/plain)
2020-03-17 19:32 UTC, Peter
no flags Details

Description Peter 2020-03-17 19:32:43 UTC
Description of problem:
Tried to open the configuration screen of Dash to Dock which had problems while loading.

Version-Release number of selected component:
gnome-tweaks-3.34.0-2.fc32

Additional info:
reporter:       libreport-2.12.0
cgroup:         0::/user.slice/user-1000.slice/user@1000.service/gnome-launched-org.gnome.tweaks.desktop-3411.scope
cmdline:        /usr/bin/python3 /usr/bin/gnome-tweaks
crash_function: _execute_child
exception_type: FileNotFoundError
executable:     /usr/bin/gnome-tweaks
interpreter:    python3-3.8.2-2.fc32.x86_64
kernel:         5.6.0-0.rc5.git0.2.fc32.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
subprocess.py:1702:_execute_child:FileNotFoundError: [Errno 2] Datei oder Verzeichnis nicht gefunden: 'gnome-shell-extension-prefs'

Traceback (most recent call last):
  File "/usr/lib/python3.8/site-packages/gtweak/tweaks/tweak_group_shell_extensions.py", line 163, in _on_configure_clicked
    execute_subprocess(['gnome-shell-extension-prefs', uuid], block=False)
  File "/usr/lib/python3.8/site-packages/gtweak/utils.py", line 105, in execute_subprocess
    p = subprocess.Popen(
  File "/usr/lib64/python3.8/subprocess.py", line 854, in __init__
    self._execute_child(args, executable, preexec_fn, close_fds,
  File "/usr/lib64/python3.8/subprocess.py", line 1702, in _execute_child
    raise child_exception_type(errno_num, err_msg, err_filename)
FileNotFoundError: [Errno 2] Datei oder Verzeichnis nicht gefunden: 'gnome-shell-extension-prefs'

Local variables in innermost frame:
self: <subprocess.Popen object at 0x7fccb5b9d910>
args: ['gnome-shell-extension-prefs', 'dash-to-dock@micxgx.gmail.com']
preexec_fn: None
close_fds: True
pass_fds: ()
cwd: None
env: None
startupinfo: None
creationflags: 0
shell: False
p2cread: 20
p2cwrite: 22
c2pread: 24
c2pwrite: 25
errread: -1
errwrite: -1
restore_signals: True
start_new_session: False
orig_executable: 'gnome-shell-extension-prefs'
errpipe_read: 26
errpipe_write: 27
low_fds_to_close: []
env_list: None
executable_list: (b'/home/peter/.cargo/bin/gnome-shell-extension-prefs', b'/home/peter/.local/bin/gnome-shell-extension-prefs', b'/home/peter/bin/gnome-shell-extension-prefs', b'/usr/share/Modules/bin/gnome-shell-extension-prefs', b'/usr/local/bin/gnome-shell-extension-prefs', b'/usr/local/sbin/gnome-shell-extension-prefs', b'/usr/bin/gnome-shell-extension-prefs', b'/usr/sbin/gnome-shell-extension-prefs', b'/home/peter/Projekte/flutter_linux_v1.9.1+hotfix.6-stable/flutter/bin/gnome-shell-extension-prefs')
fds_to_keep: {27}
errpipe_data: bytearray(b'OSError:2:')
part: b''
pid: 3792
sts: 65280
exception_name: bytearray(b'OSError')
hex_errno: bytearray(b'2')
err_msg: 'Datei oder Verzeichnis nicht gefunden'
child_exception_type: <class 'OSError'>
errno_num: 2
child_exec_never_called: False
err_filename: 'gnome-shell-extension-prefs'
executable: b'gnome-shell-extension-prefs'

Comment 1 Peter 2020-03-17 19:32:47 UTC
Created attachment 1670914 [details]
File: backtrace

Comment 2 Peter 2020-03-17 19:32:49 UTC
Created attachment 1670915 [details]
File: cpuinfo

Comment 3 Peter 2020-03-17 19:32:50 UTC
Created attachment 1670916 [details]
File: environ

Comment 4 Peter 2020-03-17 19:32:52 UTC
Created attachment 1670917 [details]
File: mountinfo

Comment 5 Peter 2020-03-17 19:32:54 UTC
Created attachment 1670918 [details]
File: namespaces

Comment 6 Peter 2020-03-17 19:32:55 UTC
Created attachment 1670919 [details]
File: open_fds

Comment 7 Mohamed El Morabity 2020-03-19 20:44:14 UTC

*** This bug has been marked as a duplicate of bug 1812779 ***


Note You need to log in before you can comment on or make changes to this bug.