Bug 181454 - yum shell help backtraces
yum shell help backtraces
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 182244 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-14 06:51 EST by Alexandre Oliva
Modified: 2014-01-21 17:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-14 08:51:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2006-02-14 06:51:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.1) Gecko/20060210 Fedora/1.5.0.1-3 Firefox/1.5.0.1

Description of problem:


Version-Release number of selected component (if applicable):
yum-2.5.1-5

How reproducible:
Always

Steps to Reproduce:
1.yum shell
2.help

Actual Results:  Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 97, in main
    result, resultmsgs = do()
  File "/usr/share/yum-cli/cli.py", line 438, in doShell
    yumshell.cmdloop()
  File "/usr/lib64/python2.4/cmd.py", line 142, in cmdloop
    stop = self.onecmd(line)
  File "/usr/lib64/python2.4/cmd.py", line 219, in onecmd
    return func(arg)
  File "/usr/share/yum-cli/shell.py", line 92, in do_help
    msg = self.base.optparser.print_short_help()
AttributeError: YumOptionParser instance has no attribute 'print_short_help'


Expected Results:  A nice and informative help message :-)

Additional info:
Comment 1 Seth Vidal 2006-02-14 08:51:28 EST
known and fixed in upstream.

thanks

will be out in 2.5.2
Comment 2 Seth Vidal 2006-02-21 08:37:51 EST
*** Bug 182244 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.