Bug 181485 - vbetool segfaults
vbetool segfaults
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pm-utils (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-14 11:33 EST by Matthias Clasen
Modified: 2015-03-04 20:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-26 01:52:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2006-02-14 11:33:57 EST
(gdb) r
Starting program: /usr/sbin/vbetool dpms suspend
Reading symbols from shared object read from target memory...done.
Loaded system supplied DSO at 0xa0f000

Program received signal SIGSEGV, Segmentation fault.
0x08049da5 in run_vm86 () at lrmi.c:534
534             asm volatile (
(gdb) bt
#0  0x08049da5 in run_vm86 () at lrmi.c:534
#1  0x0804a2b8 in LRMI_int (i=16, r=0xbfe5a280) at lrmi.c:844
#2  0x08048dec in do_vbe_service (AX=20240, BX=513, regs=0xbfe5a280)
    at vbetool.c:135
#3  0x08048f50 in do_blank (state=512) at vbetool.c:316
#4  0x08049602 in main (argc=Cannot access memory at address 0x0
) at vbetool.c:74
#5  0x005b57a4 in __libc_start_main () from /lib/i686/nosegneg/libc.so.6
#6  0x08048d21 in _start ()
Comment 1 Phil Knirsch 2006-02-15 03:54:24 EST
Tried it yesterday on a freshly updated FC-devel box and it worked like a charm
(suspended my monitor nicely... ;) )

Read ya, Phil
Comment 2 Matthias Clasen 2006-02-15 09:53:26 EST
Not good enough, Phil. It does not work on either of our test machines.
One is x86_64, the other i386.
Feel free to visit us in the megacube to check it out
Comment 3 Jeremy Katz 2006-02-28 22:15:15 EST
Matthias -- is this still failing?  I'm not seeing it fail on any of the boxes I
was doing suspend testing on today.
Comment 4 Matthias Clasen 2006-02-28 22:24:39 EST
Not in a position to test it this week.

Ray, can you update the test machines and see if this still occurs ?

Maybe it was just the xen kernel...
Comment 5 Ray Strode [halfline] 2006-02-28 23:17:11 EST
sure i'll try
Comment 6 Matthias Clasen 2006-08-26 01:52:28 EDT
Should probably close this now.

Note You need to log in before you can comment on or make changes to this bug.