Bug 181486 - Weird pipe-like characters in SWT text selection
Summary: Weird pipe-like characters in SWT text selection
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-14 16:41 UTC by Andrew Overholt
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-26 01:52:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot showing problem (9.44 KB, image/png)
2006-02-14 16:41 UTC, Andrew Overholt
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Eclipse Project 123425 None None None Never

Description Andrew Overholt 2006-02-14 16:41:01 UTC
Description of problem:
When selecting text on rawhide, I get odd vertical bars in the selection (see
attached screenshot:  gtkpipes.png).

Version-Release number of selected component (if applicable):
gtk2-2.8.12-7.1.i386

How reproducible:
Always

Steps to Reproduce:
1. Start Eclipse
2. Create a new Java Project and inside it create a new Class allowing for the
pre-stubbed main method
3. Highlight the main method
  
Actual results:
See attached

Expected results:
Clean selection highlight

Additional info:
I'm assuming this is an upstream bug but I wanted to get it documented here as
well.  I will now try to find a reference bug upstream.

Comment 1 Andrew Overholt 2006-02-14 16:41:02 UTC
Created attachment 124622 [details]
screenshot showing problem

Comment 2 Andrew Overholt 2006-02-14 17:11:40 UTC
Adding upstream reference.

Comment 3 Matthias Clasen 2006-02-14 17:20:19 UTC
Since I have not seen such drawing  errors with any other GtkTextView-using apps
in rawhide, I have to assume that eclipse is doing something odd here. Are you
inserting any strange (ie control) characters at word boundaries ?

Comment 4 Billy Biggs 2006-02-14 20:03:32 UTC
See this bug for some characters used by Eclipse:

http://bugzilla.gnome.org/show_bug.cgi?id=324621

However, that's not a GtkTextView, so bugs in the selection drawing may
be bugs in Eclipse (exposed by certain pango versions).   Probably should
be first investigated upstream.

Comment 5 Igor Foox 2006-02-16 19:41:48 UTC
Changing references upstream bugs.

Comment 6 Matthias Clasen 2006-04-19 05:26:27 UTC
This problem got tracked down to floating point environment differences.
Possible fix is planned for pango 1.12.2

Comment 7 Miles Sabin 2006-04-25 21:04:48 UTC
This appears to be fixed in pango 1.13.0 according to the changelog.

Comment 8 Matthias Clasen 2006-05-24 12:34:09 UTC
Billy, Andrew,

can you confirm that this is fixed with pango 1.13 ? 

Comment 9 Ben Konrath 2006-05-25 19:43:17 UTC
I just tested with rawhide and it's fixed with pango 1.13.


Note You need to log in before you can comment on or make changes to this bug.