Bug 181493 - hplip missing the hp-setup utility
hplip missing the hp-setup utility
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-14 12:16 EST by João Mauricio de O. Alves
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-20 11:44:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description João Mauricio de O. Alves 2006-02-14 12:16:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; pt-BR; rv:1.7.12) Gecko/20060202 Fedora/1.0.7-1.2.fc4 Firefox/1.0.7

Description of problem:
   We are unable to use the full features of HP Color LaserJet 2840 (All-in-one) over the network. We don't have a "print server" attached to the printer. We are using the network interface provided in the HP 2840.

   The system-config-printer utility does not show the printer family (the better choice seems to be Color LaserJet 2550). If we could use the hp-setup utility, I think we could use the full features of the printer.


Version-Release number of selected component (if applicable):
hplip-0.9.7-4.2

How reproducible:
Always

Steps to Reproduce:
1. Install hplip (up2date hplip)
2. hp-setup


Actual Results:  -bash: hp-setup: command not found


Expected Results:  We should have been able to use the hp-setup utility to install the printer over the network.

Alternatively, we could be able to configure the printer using system-config-printer

Additional info:

Workaround
1. Uninstall hplip (rpm -e hplip)
2. Get the hplip source from Internet
3. Install from source.
Comment 1 Tim Waugh 2006-02-17 04:15:41 EST
Please try the test update:

  https://www.redhat.com/archives/fedora-test-list/2006-February/msg01181.html

Any better?
Comment 2 João Mauricio de O. Alves 2006-02-17 06:16:34 EST
   This update fixes the problem. I removed the hplip installed from source
(make uninstall), removed all hp-* files in the /usr/bin. I got the RPM from:
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/testing/4/i386/hplip-0.9.8-3.2.i386.rpm

   Now hp-setup is working.
   I still can't configure the printer using system-config-printer, but I think
it could be subject for another bug.

   Thanks.

Note You need to log in before you can comment on or make changes to this bug.