Bug 181495 - cramfs + Zlib_Inflate
cramfs + Zlib_Inflate
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-14 12:17 EST by Hernan Otero
Modified: 2015-01-04 17:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-14 18:36:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Message from crash (3.09 KB, text/plain)
2006-02-14 12:17 EST, Hernan Otero
no flags Details
cramfs test file (1.91 MB, application/octet-stream)
2006-02-21 11:55 EST, Hernan Otero
no flags Details

  None (edit)
Description Hernan Otero 2006-02-14 12:17:11 EST
Description of problem:
trying to mount in a loop a cramfs file, the system crash

Version-Release number of selected component (if applicable):

Feb 14 15:33:16 localhost kernel: loop: loaded (max 8 devices)
Feb 14 15:33:24 localhost kernel: Unable to handle kernel paging request at 
virtual address d0e1e2d4
Feb 14 15:33:24 localhost kernel:  printing eip:
Feb 14 15:33:24 localhost kernel: c01cb782
Feb 14 15:33:24 localhost kernel: *pde = 00000000
Feb 14 15:33:24 localhost kernel: Oops: 0000 [#1]
Feb 14 15:33:24 localhost kernel: last sysfs file: /block/hdc/size
Feb 14 15:33:24 localhost kernel: Modules linked in: cramfs loop ppdev autofs4 
rfcomm l2cap bluetooth sunrpc ip_conntrack_ftp ip_conntrack_netbios_ns 
ipt_REJECT ipt_state ip_conntrack nfnetlink iptable_filter ip_tables dm_mirror 
dm_mod video button battery ac ipv6 lp parport_pc parport floppy nvram 
uhci_hcd snd_ens1371 gameport snd_rawmidi snd_ac97_codec snd_seq_dummy 
snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss 
snd_mixer_oss snd_pcm pcnet32 i2c_piix4 mii i2c_core snd_timer snd soundcore 
snd_page_alloc snd_ac97_bus ext3 jbd
Feb 14 15:33:24 localhost kernel: CPU:    0
Feb 14 15:33:24 localhost kernel: EIP:    0060:[<c01cb782>]    Not tainted VLI
Feb 14 15:33:24 localhost kernel: EFLAGS: 00000202   (2.6.15-1.1826.2.10_FC5) 
Feb 14 15:33:24 localhost kernel: EIP is at zlib_inflate+0x61/0x38b
Feb 14 15:33:24 localhost kernel: eax: d0e1e2d4   ebx: d0ada6c0   ecx: 
fffffffb   edx: d0adc05c
Feb 14 15:33:24 localhost kernel: esi: fffffffb   edi: d0e1e2d4   ebp: 
00000005   esp: c4ee5e74
Feb 14 15:33:24 localhost kernel: ds: 007b   es: 007b   ss: 0068
Feb 14 15:33:24 localhost kernel: Process ls (pid: 2721, threadinfo=c4ee5000 
task=c9c31030)
Feb 14 15:33:24 localhost kernel: Stack: d0ada6c0 00001000 c4e7e000 d0e1e2d4 
ffcb83cc d0ad0c25 00000000 c109cfc0 
Feb 14 15:33:24 localhost kernel:        ffcb83cc 00347c34 d0ad0a63 ffcb83cc 
c4e7e000 c98ac07c 00347c30 00000000 
Feb 14 15:33:24 localhost kernel:        c109cfc0 c48b948c 00000000 c013c446 
d0ad0970 c4ee5ef8 c4ee5eec 00000011 
Feb 14 15:33:24 localhost kernel: Call Trace:
Feb 14 15:33:24 localhost kernel:  [<d0ad0c25>] 
cramfs_uncompress_block+0x6d/0x9c [cramfs]     [<d0ad0a63>] 
cramfs_readpage+0xf3/0x14e [cramfs]
Feb 14 15:33:24 localhost kernel:  [<c013c446>] read_cache_page+0x7b/0x130     
[<d0ad0970>] cramfs_readpage+0x0/0x14e [cramfs]
Feb 14 15:33:24 localhost kernel:  [<c0163efc>] page_getlink+0x1c/0x55     
[<c0163f8e>] page_follow_link_light+0x14/0x21
Feb 14 15:33:24 localhost kernel:  [<c0163d38>] generic_readlink+0x25/0x68     
[<c010672d>] do_syscall_trace+0x104/0x14a
Feb 14 15:33:24 localhost kernel:  [<c0161b75>] path_lookup+0x171/0x179     
[<c0161d4f>] __user_walk+0x2a/0x31
Feb 14 15:33:24 localhost kernel:  [<c015d445>] sys_readlink+0x72/0x8b     
[<c0139876>] audit_syscall_entry+0x118/0x13f
Feb 14 15:33:24 localhost kernel:  [<c010672d>] 
do_syscall_trace+0x104/0x14a     [<c0102d15>] syscall_call+0x7/0xb
Feb 14 15:33:24 localhost kernel: Code: ff ff 8b 53 1c 83 3a 0d 0f 87 3a 03 00 
00 8b 02 ff 24 85 5c aa 2e c0 8b 43 04 85 c0 0f 84 00 03 00 00 48 89 43 04 ff 
43 08 8b 03 <0f> b6 08 8b 53 1c 89 4a 04 40 89 03 83 e1 0f 83 f9 08 8b 53 1c 
Feb 14 15:33:24 localhost kernel: Continuing in 120 seconds.
Comment 1 Hernan Otero 2006-02-14 12:17:16 EST
Created attachment 124625 [details]
Message from crash
Comment 2 Dave Jones 2006-02-18 21:12:03 EST
I can't reproduce this. I wonder if you need a specific cramfs file.
Could you make yours available somewhere, or attach it to this bug please?
Comment 3 Hernan Otero 2006-02-21 11:55:13 EST
Created attachment 124967 [details]
cramfs test file

here is the cramfs file...
Comment 4 Dave Jones 2006-03-14 18:36:59 EST
this is fixed in the 2051 kernel at
http://people.redhat.com/davej/kernels/Fedora/devel

(That'll be the final FC5 kernel)

Note You need to log in before you can comment on or make changes to this bug.