Bug 181500 - libsoup rpm doesn't include pkg-config (.pc) file
libsoup rpm doesn't include pkg-config (.pc) file
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libsoup (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-14 12:56 EST by Gabriel M. Elder
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-14 13:22:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gabriel M. Elder 2006-02-14 12:56:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.7.12-1.3.1

Description of problem:
Problems compiling anything that requires libsoup, since the .pc file is not included with the libsoup rpm package. Kind of annoying having to manually create a .pc file that should already be there...

[root@myputer pkgconfig]# rpm -qa | grep -i libsoup
libsoup-2.2.3-4.FC4
[root@myputer pkgconfig]# rpm -ql libsoup-2.2.3-4.FC4
/usr/lib/libsoup-2.2.so.7
/usr/lib/libsoup-2.2.so.7.0.0
/usr/share/doc/libsoup-2.2.3
/usr/share/doc/libsoup-2.2.3/AUTHORS
/usr/share/doc/libsoup-2.2.3/COPYING
/usr/share/doc/libsoup-2.2.3/ChangeLog
/usr/share/doc/libsoup-2.2.3/INSTALL
/usr/share/doc/libsoup-2.2.3/NEWS
/usr/share/doc/libsoup-2.2.3/README
/usr/share/doc/libsoup-2.2.3/TODO

Version-Release number of selected component (if applicable):
libsoup-2.2.3-4.FC4

How reproducible:
Always

Steps to Reproduce:
1. Install fedora core 4, including libsoup
2. look in /usr/lib/pkgconfig directory for a libsoup*.pc file
3. it's not there
  

Actual Results:  libsoup-2.2.pc is not there

Expected Results:  it should be, for developers' / compiling convenience

Additional info:

would this qualify as a suitable libsoup-2.2.pc? to help get somebody started on this?

prefix=/usr
exec_prefix=${prefix}
libdir=${exec_prefix}/lib
includedir=${prefix}/include
SOUP_API_VERSION=2.2

Name: libsoup
Description: a glib-based HTTP library
Version: 2.2.3
Requires: glib-2.0
Libs: -L${libdir} -lsoup-${SOUP_API_VERSION} -lz -L/usr/lib -lgnutls -lgcrypt -lgpg-error -lxml2 -lpthread -lz -lm
Cflags: -I${includedir}/libsoup-${SOUP_API_VERSION} -I/usr/include/libxml2
Comment 1 Gabriel M. Elder 2006-02-14 13:22:30 EST
Sorry, my oops. The .pc file is in the libsoup-devel package; i did a "yum
install libsoup-devel" and stuff seems better now. I could've sworn, based on
previous versions of fedora core, that the .pc was in the libsoup rpm; oh well.

Note You need to log in before you can comment on or make changes to this bug.