Bug 181503 - No automatic login
No automatic login
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Mike McLean
:
: 189701 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-14 13:01 EST by Tim Waugh
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-20 12:43:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2006-02-14 13:01:11 EST
Description of problem:
The 'automatic login' feature does not work.

Firstly, the drop-down list of usernames in gdmsetup does not list any users
even when there is one.

Secondly, when a username is entered manually and the machine rebooted, the user
is not automatically logged in.

Version-Release number of selected component (if applicable):
gdm-2.13.0.7.0.2006.02.12-1

How reproducible:
100%
Comment 1 Matthias Clasen 2006-02-25 16:44:54 EST
Tim, you need to first go the the Users tab, and either check the 
"All users from passwd" checkbox or add some users to the include list.
After that, you can select a user from the combobox, and automatic login 
works (for me, at least)
Comment 2 Tim Waugh 2006-02-27 10:10:10 EST
I had to restart the application in order to get the combobox populated.
Comment 3 Rahul Sundaram 2006-03-05 00:55:05 EST

The "all users from password" combobox should probably be on by default and the
application shouldnt require a restart. The entire interface makes it non obvious. 
Comment 4 Marius Andreiana 2006-04-02 06:24:29 EDT
I second Rahul's comment (current way it's non-intuitive, I was about to fill a
bug with Automatic login doesn't work)
Comment 5 Andrew 2006-05-10 11:45:47 EDT
>Secondly, when a username is entered manually and the machine rebooted, the user
> is not automatically logged in.

I think that's the same as issue 188326.
Comment 6 Dario Lesca 2006-06-20 11:07:57 EDT
whit the last version of gdm (gdm-2.14.8-1) when the autologin start, I see a
black screen with a small text box that says:

 | Automatic login (user)
 | Password:

and then if I type in the password, the login proceeds as usual.
Comment 7 Andy Burns 2006-06-25 15:58:53 EDT
I previously had a problem where gdm didn't use the auto-login set by gdmsetup
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=188463

I had to manually edit /etc/gdm/custom.conf to egt auto-login working

the latest update to gdm has now broken auto-login, it now prompts for the
password of the auto-login user.


Comment 8 Andy Burns 2006-08-20 12:26:55 EDT
re comment #7, subsequent Fc5 updates have restored this functionality again for me
Comment 9 Rahul Sundaram 2006-08-20 13:14:07 EDT
The interface improvement suggested earlier is filed as a new enhancement
request in https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=203287
Comment 10 Ray Strode [halfline] 2007-08-20 17:46:06 EDT
*** Bug 189701 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.