Bug 1815541 - Fedora 32 Touchpad is not working on Thinkpad X1 Carbon
Summary: Fedora 32 Touchpad is not working on Thinkpad X1 Carbon
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-20 14:23 UTC by bengt
Modified: 2020-05-06 23:10 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-06 21:35:05 UTC
Type: Bug


Attachments (Terms of Use)
kernel log (87.12 KB, text/plain)
2020-03-20 14:23 UTC, bengt
no flags Details

Description bengt 2020-03-20 14:23:58 UTC
Created attachment 1671928 [details]
kernel log

1. Please describe the problem:
Touchpad is not working after fresh install or upgrade from 31.
Thinkpad X1 Carbon Gen 3
Synaptics TM3075-003


2. What is the Version-Release number of the kernel:
5.6.0-0.rc5.git0.2.fc32.x86_64


3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :
Yes worked on 31 latest kernel
5.5.9-200.fc31.x86_64


4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:
Install Fedora 32 or upgrade from 31


5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:
Not tried.


6. Are you running any modules that not shipped with directly Fedora's kernel?:
No


7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.

Workaround:
GRUB_CMDLINE_LINUX_DEFAULT=“psmouse.synaptics_intertouch=0” solve the issue.

Comment 1 Steve 2020-05-06 17:45:17 UTC
Thanks for your report and for attaching a log. Does suspend/resume work as expected?

From the attached log:

$ egrep 'Command line|DMI:|ThinkPad ACPI Extras' dmesg.txt

Mar 20 15:18:07 kernel: Command line: BOOT_IMAGE=(hd0,gpt2)/vmlinuz-5.6.0-0.rc5.git0.2.fc32.x86_64 root=/dev/mapper/fedora_fedora--x1-root ro resume=/dev/mapper/fedora_fedora--x1-swap rd.lvm.lv=fedora_fedora-x1/root rd.lvm.lv=fedora_fedora-x1/swap rhgb quiet

Mar 20 15:18:07 kernel: DMI: LENOVO 20BT003VMS/20BT003VMS, BIOS N14ET53W (1.31 ) 11/12/2019

Mar 20 15:18:11 kernel: thinkpad_acpi: ThinkPad ACPI Extras v0.26

$ fgrep -A10 'ACPI: [Firmware Bug]:' dmesg.txt
Mar 20 15:18:07 kernel: ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
Mar 20 15:18:07 kernel: ACPI Error: Needed type [Reference], found [Integer] 000000002cbb1b4e (20200110/exresop-66)
Mar 20 15:18:07 kernel: ACPI Error: AE_AML_OPERAND_TYPE, While resolving operands for [OpcodeName unavailable] (20200110/dswexec-424)
Mar 20 15:18:07 kernel: ACPI Error: Aborting method \_PR.CPU0._PDC due to previous error (AE_AML_OPERAND_TYPE) (20200110/psparse-529)
Mar 20 15:18:07 kernel: ACPI: Dynamic OEM Table Load:
Mar 20 15:18:07 kernel: ACPI: SSDT 0xFFFF9081041F0000 0005AA (v01 PmRef  ApIst    00003000 INTL 20120711)
Mar 20 15:18:07 kernel: ACPI: Dynamic OEM Table Load:
Mar 20 15:18:07 kernel: ACPI: SSDT 0xFFFF9081040A4600 000119 (v02 PmRef  ApCst    00003000 INTL 20120711)
Mar 20 15:18:07 kernel: ACPI: Interpreter enabled
Mar 20 15:18:07 kernel: ACPI: (supports S0 S3 S4 S5)
Mar 20 15:18:07 kernel: ACPI: Using IOAPIC for interrupt routing

Comment 2 Steve 2020-05-06 17:56:21 UTC
I'm not sure if this is normal or not, but the first SMBus access appears to have stalled or failed:

$ fgrep -C0 -i -n 'synaptics' dmesg.txt
728:Mar 20 15:18:07 kernel: psmouse serio1: synaptics: queried max coordinates: x [..5676], y [..4758]
729:Mar 20 15:18:07 kernel: psmouse serio1: synaptics: queried min coordinates: x [1266..], y [1096..]
730:Mar 20 15:18:07 kernel: psmouse serio1: synaptics: Trying to set up SMBus access
731:Mar 20 15:18:07 kernel: psmouse serio1: synaptics: SMbus companion is not ready yet <<<<<<<<<<<<<<<<<<<
732:Mar 20 15:18:07 kernel: psmouse serio1: synaptics: Touchpad model: 1, fw: 8.1, id: 0x1e2b1, caps: 0xf003a3/0x943300/0x12e800/0x10000, board id: 3072, fw id: 1795685
733:Mar 20 15:18:07 kernel: psmouse serio1: synaptics: serio: Synaptics pass-through port at isa0060/serio1/input0
--
737:Mar 20 15:18:07 kernel: input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input5
--
1031:Mar 20 15:18:12 kernel: psmouse serio1: synaptics: queried max coordinates: x [..5676], y [..4758]
1032:Mar 20 15:18:12 kernel: psmouse serio1: synaptics: queried min coordinates: x [1266..], y [1096..]
1033:Mar 20 15:18:12 kernel: psmouse serio1: synaptics: Trying to set up SMBus access
--
1048:Mar 20 15:18:14 kernel: rmi4_f01 rmi4-00.fn01: found RMI device, manufacturer: Synaptics, product: TM3072-003, fw id: 1795685
1049:Mar 20 15:18:14 kernel: input: Synaptics TM3072-003 as /devices/rmi4-00/input/input19

Comment 3 Steve 2020-05-06 18:00:40 UTC
Maximilian: Could you look at the ACPI errors in the attached log and see if they seem to be related to:

Bug 1830150 - [BISECTED] Fedora 31 with kernel 5.6 does not wake up from suspend

Comment 4 Maximilian Luz 2020-05-06 19:43:00 UTC
(In reply to Steve from comment #3)
> Maximilian: Could you look at the ACPI errors in the attached log and see if
> they seem to be related to:
> 
> Bug 1830150 - [BISECTED] Fedora 31 with kernel 5.6 does not wake up from

Based on the logs, I believe this is a different issue. 1830150 is about previous conversion to Integer, which are now Buffer.

  Needed type [Reference], found [Integer].

would indicate that it finds an Integer. If it were related to 1830150, I think we should see something like

  Needed type [Integer], found [Buffer].

Nevertheless, could anyone upload an acpidump of the affected device so I can make completely sure this isn't related?

Comment 5 Steve 2020-05-06 20:34:18 UTC
Maximilian: Thanks for looking at the log.

bengt: Can you reproduce the touchpad problem with:

kernel-5.6.10-300.fc32 and kernel-headers-5.6.10-300.fc32 
https://bodhi.fedoraproject.org/updates/FEDORA-2020-95398cdb5e

It's not clear if the ACPI error is related or not, but if you get an error like that in Comment 1 from this:

$ journalctl --no-hostname -k | fgrep -A3 'ACPI: [Firmware Bug]'

Could you install the acpica-tools package, if needed:

# dnf install acpica-tools

And attach the output from this:

# acpidump > /tmp/acpidump-1.txt

Comment 6 bengt 2020-05-06 21:35:05 UTC
Thank you for looking in to this bug.

I tried to reproduce today with 5.6.8-300.fc32.x86_64, and the touchpad is working without the kernel parameter.

So this bug can be closed.

Please tell me if you want more logs for research.

Thank you.

Comment 7 Steve 2020-05-06 23:10:23 UTC
(In reply to bengt from comment #6)
> Thank you for looking in to this bug.
> 
> I tried to reproduce today with 5.6.8-300.fc32.x86_64, and the touchpad is working without the kernel parameter.
> 
> So this bug can be closed.
> 
> Please tell me if you want more logs for research.
> 
> Thank you.

Thanks for your follow-up report and for closing the bug. If everything is working as expected, no more logs are needed. Please reopen if the problem re-occurs.


Note You need to log in before you can comment on or make changes to this bug.