Bug 181565 - cryptoloop broken: Invalid argument
cryptoloop broken: Invalid argument
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-14 17:14 EST by Need Real Name
Modified: 2015-01-04 17:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-04 18:54:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2006-02-14 17:14:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060212 Epiphany/1.9.6

Description of problem:
http://www.freeotfe.org/docs/Linux_examples__cryptoloop.htm#ac

# modprobe cryptoloop
# modprobe aes_i586
# dd if=/dev/zero of=./vol_aes128 bs=1k count=1024
# losetup -e AES128 /dev/loop0 ./vol_aes128
Password:
ioctl: LOOP_SET_STATUS: Invalid argument

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:
Comment 1 Dave Jones 2006-03-04 18:54:08 EST
use 'aes' instead of 'aes128'.
refer to the 'name' in /proc/crypto
Comment 2 Need Real Name 2006-03-04 19:04:11 EST
Great. Thanks. Get a Permission denied error though, due to selinux.
Worth moving?
Comment 3 Dave Jones 2006-03-04 20:55:24 EST
please file another bug against selinux-policy-targeted with the avc denial messages

Note You need to log in before you can comment on or make changes to this bug.