Bug 181575 - sky2 driver won't come up until a usb pen-drive gets plugged in!
sky2 driver won't come up until a usb pen-drive gets plugged in!
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-14 18:08 EST by Lars Damerow
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-17 16:35:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
full lspci output for laptop (17.00 KB, text/plain)
2006-02-14 18:08 EST, Lars Damerow
no flags Details

  None (edit)
Description Lars Damerow 2006-02-14 18:08:33 EST
Description of problem:
My laptop has a Marvell 88E8053 PCI-E Gigabit network controller (11ab:4362).
When I boot it after having just upgraded from FC4 to FC5test2, the sky2 driver
fails to bring up the interface with the following complaint:

  sky2 v0.15 addr 0xcdffc000 irq 10 Yukon-EC (0xb6) rev 1
  sky2 eth0: addr 00:0e:7b:6a:09:9e
  sky2 0000:02:00.0: No interrupt was generated using MSI, switching to INTx
mode. Please report this failure to the PCI maintainer and include system
chipset information.
  sky2 eth0: enabling interface
  ADDRCONF(NETDEV_UP): eth0: link is not ready
  sky2 eth0: Link is up at 100 Mbps, full duplex, flow control both
  ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
  sky2 eth0: disabling interface

This persists despite unloading and reloading the sky2 module.

The weird thing is that I plugged in a USB pen drive to put the sk98lin source
on the laptop. As soon as I plugged the drive in, the sky2 interface came up and
the network was accessible! I repeated this more than once. The network
continues to work after the USB drive is removed.

According to /proc/interrupts, part of the USB bus is sharing an interrupt with
the sky2 device:

  10:     138495          XT-PIC  uhci_hcd:usb5, sky2

I'll attach the full output of lspci -vv in case it's useful.

Thanks!
-lars

Version-Release number of selected component (if applicable):
kernel-2.6.15-1.1831_FC4

How reproducible:
Always

Steps to Reproduce:
1. Boot laptop
2. Wait for eth0 to get a DHCP address--it fails
3. Plug in USB drive and watch the network connect properly
  
Actual results:
Network won't be accessible until USB drive gets plugged in

Expected results:
Network would just be accessible without any interaction
Comment 1 Lars Damerow 2006-02-14 18:08:33 EST
Created attachment 124654 [details]
full lspci output for laptop
Comment 2 Rahul Sundaram 2006-02-20 05:53:25 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 3 John W. Linville 2006-02-20 11:54:01 EST
This almost sounds like an ACPI problem.  Have you tried booting w/ acpi=off? 
 
Comment 4 Lars Damerow 2006-03-17 16:35:41 EST
I updated to the latest rawhide kernel (2.6.15-1.2054_FC5) and all is well now.
I'll close the bug report.

Thanks!
-lars

Note You need to log in before you can comment on or make changes to this bug.