Bug 1815765 - Failed to execute stage 'Misc configuration': 'ascii' codec can't decode byte 0xd0 in position 79: ordinal not in range(128)
Summary: Failed to execute stage 'Misc configuration': 'ascii' codec can't decode byte...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine-extension-aaa-ldap
Classification: oVirt
Component: General
Version: 1.3.10
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ovirt-4.4.0
: ---
Assignee: Martin Perina
QA Contact: Petr Matyáš
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-21 14:17 UTC by Dmitry
Modified: 2020-05-20 20:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-20 20:00:17 UTC
oVirt Team: Integration
sbonazzo: ovirt-4.4?
sbonazzo: devel_ack+


Attachments (Terms of Use)
The log after the item "Select test sequence to execute (Done, Abort, Login, Search) [Done]:" (28.54 KB, text/plain)
2020-03-21 14:17 UTC, Dmitry
no flags Details

Description Dmitry 2020-03-21 14:17:52 UTC
Created attachment 1672210 [details]
The log after the item "Select test sequence to execute (Done, Abort, Login, Search) [Done]:"

Description of problem:
When I run ovirt-engine-extension-aaa-ldap-setup with joining the AD, after passing a successful user search test I get "[ERROR] Failed to execute stage 'Misc configuration': 'ascii' codec can't decode byte 0xd0 in position 79: ordinal not in range (128) ".

Version-Release number of selected component (if applicable):
1. ovirt-engine-extension-aaa-ldap-setup.noarch  1.3.10-1.el7  @ovirt-4.3
2. otopi-1.8.4 (otopi-1.8.4-1.el7)
3. Python 2.7.5


How reproducible:
100%

Steps to Reproduce:
1. run ovirt-engine-extension-aaa-ldap-setup for Active directory

Actual results: 
Incorrect installation completion.


Expected results: 
Successfully complete the installation and authorization through the domain.


Additional info:
[ INFO  ] Login sequence executed successfully
          Please make sure that user details are correct and group membership meets expectations (search for PrincipalRecord and GroupRecord titles).
          Abort if output is incorrect.
          Select test sequence to execute (Done, Abort, Login, Search) [Done]: 
[ INFO  ] Stage: Transaction setup
[ INFO  ] Stage: Misc configuration (early)
[ INFO  ] Stage: Package installation
[ INFO  ] Stage: Misc configuration
[ ERROR ] Failed to execute stage 'Misc configuration': 'ascii' codec can't decode byte 0xd0 in position 79: ordinal not in range(128)
[ INFO  ] Stage: Clean up
          Log file is available at /tmp/ovirt-engine-extension-aaa-ldap-setup-20200321163411-a5jtzm.log:
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination

Comment 1 Sandro Bonazzola 2020-04-01 07:54:17 UTC
can we try to reproduce this on 4.4 which uses python3 and unicode as default?

Comment 2 Petr Matyáš 2020-04-01 10:15:35 UTC
Using ovirt-engine-4.4.0-0.26.master.el8ev.noarch with ovirt-engine-extension-aaa-ldap-1.4.0-1.el8ev.noarch

I tested adding an AD domain using users 'фыва' and 'český' and setup worked for both of them without problems.

Comment 3 Dmitry 2020-04-05 10:25:55 UTC
Reading a varied message about this problem in google, I can conclude that this is exactly Python 2, it seems that there is no such problem in Python 3, and most likely everything will work correctly there.
For myself, I solved this problem by setting up AD through configuration files.

p.s: if necessary, I can post my configs for configuration.

Comment 4 Sandro Bonazzola 2020-05-20 20:00:17 UTC
This bugzilla is included in oVirt 4.4.0 release, published on May 20th 2020.

Since the problem described in this bug report should be
resolved in oVirt 4.4.0 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.