Bug 181600 - CIJK install gives AnacondaYum backtrace
CIJK install gives AnacondaYum backtrace
Status: CLOSED DUPLICATE of bug 181585
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-14 22:25 EST by Jens Petersen
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-15 10:14:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2006-02-14 22:25:30 EST
Description of problem:
When doing a default install of recent rawhide in Japanese I get the backtrace
below.

Version:
rawhide-20060214

How reproducible:
everytime 

Steps to Reproduce:
1. install FC devel in Japanese
  
Actual results:
Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 948, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 146, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 217, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/backend.py", line 151, in doPostSelection
    backend.doPostSelection(intf, id, instPath)
  File "/usr/lib/anaconda/yuminstall.py", line 751, in doPostSelection
    self.selectConditionalPackages()
  File "/usr/lib/anaconda/yuminstall.py", line 745, in selectConditionalPackages
    self.ayum.selectPackage(pkg)
AttributeError: 'AnacondaYum' object has no attribute 'selectPackage'

Local variables in innermost frame:
self: <yuminstall.YumBackend instance at 0x2afbffc9f128>
cond: xorg-x11-server-Xorg
pkg: scim-anthy
g: Japanese Support

Expected results:
No backtrace.

Additional info:
Also happened with 20060212 rawhide.
(This is a boot.iso http install on x86_64 if it should matter.)
Full backtrace available on request.
Comment 1 Chris Lumens 2006-02-15 10:14:40 EST

*** This bug has been marked as a duplicate of 181585 ***

Note You need to log in before you can comment on or make changes to this bug.