Bug 181604 - Gnome screen shot can't operate when menu item is active.
Gnome screen shot can't operate when menu item is active.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
rawhide
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-15 05:19 EST by Naoki
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-15 10:33:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Naoki 2006-02-15 05:19:17 EST
Description of problem:

"Print Screen" key doesn't work when you have an active menu item, for example
click on Applications and bring down the menu, hit Print screen and nothing happens.


Version-Release number of selected component (if applicable):

gnome-utils-2.13.92-1

How reproducible:

Always.

Steps to Reproduce:
1. Click "Applications" menu item.
2. Press "Print Screen".

  
Actual results:

Nothing.

Expected results:

Cursor turns into hour-glass, and a "Save screen shot" dialog appears.
Additional info:
Comment 1 Ray Strode [halfline] 2006-02-15 10:33:25 EST
Hi Naoki,

Believe it or not, this is really a rather hard problem to fix.  The problem is
when menus are active, they ask the windowing system to send all mouse and
keyboard events to them.

A workaround for your specific case might be to create a custom launcher that
runs /usr/bin/gnome-screenshot --delay=5  (where 5 is 5 seconds).  Then you can
click the custom launcher immediately click the menu you want afterward.
Comment 2 Naoki 2006-02-17 01:23:39 EST
Cheers, a workaround is no issue.  Just seems odd. Is this a "won't fix" because
it's a design flaw therefore in the too hard basket? I understand the menus are
taking all events, but why?

Note You need to log in before you can comment on or make changes to this bug.