Bug 181674 - test.pl script crashes with auto/Newt/Listbox/Add.al not found
test.pl script crashes with auto/Newt/Listbox/Add.al not found
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: newt-perl (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-15 15:15 EST by Charlie Brady
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-14 11:39:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charlie Brady 2006-02-15 15:15:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 CentOS/1.0.7-1.4.1.centos4 Firefox/1.0.7

Description of problem:
Test script barfs.

Can't locate auto/Newt/Listbox/Add.al in @INC (@INC contains: /usr/lib/perl5/5.8.5/i386-linux-thread-multi /usr/lib/perl5/5.8.5 /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.2/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.2/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl/5.8.4 /usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl/5.8.2 /usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl .) at test.pl line 41


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
rpmbuild -bp ../SPECS/newt-perl.spec
cd Newt-1.08
perl Makefile.PL
make
make test
  

Additional info:

Fix is easy:

--- test.pl.orig        2006-02-15 15:12:33.590548000 -0500
+++ test.pl     2006-02-15 15:07:35.323946000 -0500
@@ -38,7 +38,7 @@
 $ok = Newt::Button("Ok", 0);
 $ok->Tag("OK");
 $li = Newt::Listbox(5, NEWT_FLAG_SCROLL | NEWT_FLAG_BORDER | NEWT_FLAG_MULTIPLE);
-$li->Add('Red', 'Blue', 'Yellow', 'Gray', 'Green');
+$li->Append('Red', 'Blue', 'Yellow', 'Gray', 'Green');
 $panel1 = Newt::Panel(2, 4, "Panel example");
 $panel1->AddHotKey(NEWT_KEY_F11);
 $panel2 = Newt::Panel(1, 2, "Second panel");
Comment 1 Joe Orton 2006-12-14 11:39:53 EST
Thanks for the patch.  This will be integrated into future releases but will not
warrant inclusion in a RHEL update since it only affects example code.

Note You need to log in before you can comment on or make changes to this bug.