Bug 181713 - lyx-1.3.7 needs to be built for FC-4
lyx-1.3.7 needs to be built for FC-4
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: lyx (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-15 18:48 EST by Alex Lancaster
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-17 08:09:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2006-02-15 18:48:15 EST
Description of problem:

It looks like the spec has been updated for lyx-1.3.7:

http://cvs.fedora.redhat.com/viewcvs/rpms/lyx/FC-4/lyx.spec?root=extras&rev=1.16&view=auto

But lyx-1.3.6-4.fc4 is the latest available from the repository.

Version-Release number of selected component (if applicable):

lyx-1.3.6-4.fc4

How reproducible:

Always

Steps to Reproduce:
1. yum install lyx


Actual results:

Only lyx-1.3.6 is installed

Expected results:

lyx-1.3.7-5.fc4 should be installed

Additional info:
Comment 1 Rex Dieter 2006-02-16 00:04:56 EST
Last time I tried submitting builds, the buildsystem wasn't working.  Thanks for
reminding me to resubmit the job.
Comment 2 Rex Dieter 2006-02-16 10:40:29 EST
 4525 (lyx): Build on target fedora-4-extras succeeded.
     Build logs may be found at
http://buildsys.fedoraproject.org/logs/fedora-4-extras/4525-lyx-1.3.7-5.fc4/
Comment 3 Alex Lancaster 2006-02-17 03:16:35 EST
It appears that upgrading lyx, installs lyx-xforms, as the graphics backend, but
not lyx-qt, the qt backend.  Given that the 1.3.6 version exclusively used the
qt GUI, it violates the principle of least surprise that the upgrade doesn't
include the qt backend, so I would expect that an upgrade should install the
lyx-qt backend rather than the xforms backend.
Comment 4 Alex Lancaster 2006-02-17 03:27:23 EST
i.e. lyx-xforms should be the optional package, rather than the default.
Comment 5 Rex Dieter 2006-02-17 07:38:28 EST
Actually, you can install *either* lyx-qt or lyx-xforms.  There is no default.

In my testing, a regular
yum update
installed lyx-qt. ??  I guessed that was because yum chose lyx-qt over
lyx-xforms because it comes first alphabetically, but now, who knows?
Comment 6 Alex Lancaster 2006-02-17 08:06:12 EST
I was actually using smart, not yum, to upgrade, it chose lyx-xforms.  It has a
slighly different depsolver to figure out what to upgrade.  Still, I think that
for somebody who is *upgrading* from lyx-1.3.6, lyx-qt should always be
installed, because that mirrors the 1.3.6 functionality.  Of course, *after*
that installation they can chose between lyx-xforms and lyx-qt (or both).  

Presumably lyx is non-functional without one or the other, though, so *some*
default needs to be chosen for upgrades.

I'll test what both to see what smart and yum do.
Comment 7 Rex Dieter 2006-02-17 08:09:57 EST
I chose not to make any default so folks that want lyx-xforms won't have to
install lyx-qt too, even though they don't use it.

Regardless, *this* bug (lyx-1.3.7 needs to be built for FC-4) is closed.  

If you want to pursue this other issue, please open a new report.
Comment 8 Alex Lancaster 2006-02-17 08:17:26 EST
OK, here's what smart and yum do:

smart upgrades to lyx-xforms

$ sudo smart upgrade
Loading cache...
Updating cache...               ######################################## [100%]

Computing transaction...

Upgrading packages (1):
  lyx-1.3.7-5.fc4@i386

Installed packages (1):
  lyx-xforms-1.3.7-5.fc4@i386

5.8MB of package files are needed. 1.5MB will be freed.

Confirm changes? (Y/n): n

But yum upgrades to lyx-qt.

$ sudo yum install lyx
Setting up Install Process

[...]
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package lyx.i386 0:1.3.7-5.fc4 set to be updated
--> Running transaction check
--> Processing Dependency: lyx-frontend = 1.3.7 for package: lyx
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package lyx-qt.i386 0:1.3.7-5.fc4 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Updating:
 lyx                     i386       1.3.7-5.fc4      extras            3.9 M
Installing for dependencies:
 lyx-qt                  i386       1.3.7-5.fc4      extras            1.9 M

Transaction Summary
=============================================================================
Install      1 Package(s)
Update       1 Package(s)
Remove       0 Package(s)
Total download size: 5.8 M
Is this ok [y/N]:

Doing a fresh install, smart again only wants to install lyx-xforms:

$ sudo smart install lyx
Computing transaction...

Installed packages (2):
  lyx-1.3.7-5.fc4@i386                   lyx-xforms-1.3.7-5.fc4@i386

5.8MB of package files are needed. 20.9MB will be used.

Confirm changes? (Y/n): n

Whereas yum again chooses qt:

$ sudo yum install lyx
--> Populating transaction set with selected packages. Please wait.
---> Package lyx.i386 0:1.3.7-5.fc4 set to be updated
--> Running transaction check
--> Processing Dependency: lyx-frontend = 1.3.7 for package: lyx
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package lyx-qt.i386 0:1.3.7-5.fc4 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 lyx                     i386       1.3.7-5.fc4      extras            3.9 M
Installing for dependencies:
 lyx-qt                  i386       1.3.7-5.fc4      extras            1.9 M

Transaction Summary
=============================================================================
Install      2 Package(s)
Update       0 Package(s)
Remove       0 Package(s)
Total download size: 5.8 M
Is this ok [y/N]:

I think the requires should be amended so that lyx-qt is always installed, so
that smart will also do the right thing like yum does.  It bothers me that the
upgrade path is non-deterministic and in this case, just happens to depend on
which package manager you are using, it should be under the control of the packager.
Comment 9 Rex Dieter 2006-02-17 08:22:46 EST
I'm strongly against forcing any particular front-end on anyone.  End users
should be free to choose.

If you don't like that, and have an idea on how to implement your wishes and
mine, I'd love to hear it (in a separately filed bugzilla report please).
Comment 10 Alex Lancaster 2006-02-17 08:26:06 EST
(In reply to comment #7)
> I chose not to make any default so folks that want lyx-xforms won't have to
> install lyx-qt too, even though they don't use it.

Understood.  If lyx-xform is explicitly chosen, then lyx-qt should *not* be
installed, I'm only talking about the case of either upgrading from lyx-1.3.6
*or* if only lyx is specified (with no explicit request for either -qt or -xforms).

> Regardless, *this* bug (lyx-1.3.7 needs to be built for FC-4) is closed.  

Sure.
 
> If you want to pursue this other issue, please open a new report.

bug #181878.

Note You need to log in before you can comment on or make changes to this bug.