Bug 181737 - timezone --utc in kickstart file ignored if MS-Windows is found
timezone --utc in kickstart file ignored if MS-Windows is found
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-15 23:29 EST by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-14 13:58:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2006-02-15 23:29:10 EST
Description of problem:
The timezone specified in the timezone line in a kickstart file selects the
right timezone, but if --utc is there, it makes no difference to the timezone
selection screen, at least in an interactive install: the UTC check box is not
checked.

Version-Release number of selected component (if applicable):
anaconda-10.92.4-1

How reproducible:
Every time

Steps to Reproduce:
1.Create a kickstart file with timezone --utc America/Sao_Paulo, for an
interactive kickstart install
2.Start the installer using that file

Actual results:
When you get to the timezone screen, the UTC check box is not checked, and the
installed system does not assume the BIOS clock is in UTC

Expected results:
The box should be checked, and the directive should take effect

Additional info:
It might be that a non-interactive install works, but I sort of doubt it.  It's
more likely another fallout from the ks parser rewrite.
Comment 1 Alexandre Oliva 2006-02-16 06:40:31 EST
FWIW, I've verified that a non-interactive install works.  It only drops --utc
in interactive ks installs.
Comment 2 Chris Lumens 2006-02-16 10:17:10 EST
Close, but this is actually fallout from reworking the timezone screen.  Too
late for test 3, but this will be fixed in Rawhide.
Comment 3 Alexandre Oliva 2006-08-04 12:46:50 EDT
This is back in the current tree :-(  In the interactive install, the local time
is in UTC button is not checked even though I have the --utc option in the ks
file.  Unfortunately I can't test non-interactive installs atm due to other
installer bugs :-(
Comment 4 Alexandre Oliva 2006-08-04 13:38:06 EDT
Hmm...  Odd...  On another box, it worked.  Differences: the one on which it
didn't work is x86_64, whereas the other is i386; the working one didn't boot
with `expert', but the faulty one did because it has a USB disk on raid 1 for
the root-containing volume group physical volumes.  I hope this helps.

I've double-checked the timezone line, and they are bit-by-bit identical on both
boxes.
Comment 5 Chris Lumens 2006-08-08 12:08:48 EDT
Anything in the log files for the machine that doesn't work?
Comment 6 Alexandre Oliva 2006-08-09 00:47:06 EDT
Nope, but it hit me when I proceeded to install it on another notebook that also
had a MS-Windows left-over :-)

./iw/timezone_gui.py:        self.utcCheckbox.set_active(not
hasWindows(anaconda.id.bootloader))

Surely this shouldn't override the ks setting.  I don't care if Windows gets the
time wrong (I never use it anyway :-)
Comment 7 Chris Lumens 2006-08-09 10:18:53 EDT
Ah yes, that would do it.  Thanks for figuring that out.  Let me know if the
next anaconda build works better for you.

Note You need to log in before you can comment on or make changes to this bug.