Bug 18182 - Failed install
Failed install
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
: 18388 18488 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-03 01:24 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-26 18:10:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-03 01:24:53 EDT
This message happened during a RedHat 7.0 install while trying to format my
partitions.

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line
20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1472, in
doInstall
    self.fstab.mountFilesystems (self.instPath)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 713, in
mountFilesystems
    raise SystemError, (errno, msg)
SystemError: (22, 'Invalid argument')

Local variables in innermost frame:
size: 2072385
fsystem: ext2
self: <fstab.GuiFstab instance at 8446af0>
msg: Invalid argument
doFormat: 1
errno: 22
device: hda2
instPath: /mnt/sysimage
mntpoint: /

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Michael Fulbright 2000-10-03 15:39:20 EDT
Did you choose to not format the '/' partition - it appears it was not.
Comment 2 Chris Chabot 2000-10-04 08:10:05 EDT
please see my bug report on install:
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=18320

i was only able to install on some systems by mknod'ing, and mkfs.ext2'ing the
partitions by hand, the standard format didnt perform this for me, and would
cause the same error..  this on a total of 5 tested systems so far, mixed from
servers to workstations, to notebooks (ide, scsi, ide&scsi)
Comment 3 Need Real Name 2000-10-04 08:28:07 EDT
I did choose to format '/'
I also selected the "Check for bad blocks" option.

I suspect it tried the format and failed which caused this error.
Comment 4 Michael Fulbright 2000-10-09 14:33:00 EDT
Is this problem reproducible?
Comment 5 Michael Fulbright 2000-10-09 15:57:21 EDT
*** Bug 18488 has been marked as a duplicate of this bug. ***
Comment 6 Michael Fulbright 2000-10-09 15:58:18 EDT
*** Bug 18388 has been marked as a duplicate of this bug. ***
Comment 7 Need Real Name 2000-10-10 08:38:28 EDT
No, this is not repeatable.

I did the install a second time without re-fdisk'ing the disk but I did choose
to format the partition again and the install worked.

I have a 26Gb drive and I placed a 2Gb partition plus swap at the end of the
drive.

This system had RedHat 6.1 on it previously but, I did not upgrade. I wanted a
new install.

Hope this info helps....
Comment 8 Chris Chabot 2000-10-10 08:50:03 EDT
This bug should be fixed by the recently released anaconda update ( see
http://www.lwn.net/daily/rh7-anaconda.php3 ). There were multiple problems with
handling existing partitions, and ext2 partition labels.. I tried to reinstall
with the new boot-disk, and it didnt crap out on the format/mounting anymore ...
thus solving this bug for me..

as far as im concerned, i think this bug could be marked 'solved & closed'

many thnx to the redhat bugfixers for this .. im sure they didnt sleep much in
the last week(s)

Note You need to log in before you can comment on or make changes to this bug.