Bug 18185 - Bug in the Kerberos ftp client on Red Hat 6.2?
Bug in the Kerberos ftp client on Red Hat 6.2?
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: krb5 (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-03 02:20 EDT by Chris Rasch
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 13:00:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Rasch 2000-10-03 02:20:28 EDT
There appears to be a problem with the Kerberos ftp client
(usr/kerberos/bin/ftp) auto-authentication routines.   Here's a history of
the problem I've had:

I just installed Xemacs-21.1.11 (Carlsbad Caverns) on a new installation of
Red Hat 6.2.  I also downloaded and untarred  the
xemacs-sumo-2000-09-04.tar.gz into the /usr/local/lib/xemacs/ directory. 
When I attempted to "Update Installed Packages" (from any of the U.S.
mirrors), I got the following error messages:

Open Metalab.Unc.Edu
Connected To Metalab.Unc.Edu.
220 Helios.Oit.Unc.Edu Ftp Server (Version Wu-2.6.1(1) Sat Jul 8
10:18:10 Edt 2000) Ready.
Quote User "Anonymous"
530 Please Login With User And Pass.

If  I tried to open an ftp connection to /ftp.xemacs.org:/ I get:

Opening FTP connection to ftp.emacs.org...
Logging in as user anonymous...
FTP error: USER request failed: 500 AUTH not understood

Judging from the error codes, the problem is with the ftp client.
Output from ps -Afl, during an attempt to login to ftp.xemacs.org from
within Xemacs indicates that Xemacs is using  /usr/kerberos/bin/ftp as the
ftp client:

000 S root     12825 12715  3  73   0    -   562 read_c 03:45 ttyp2
00:00:00 /usr/kerberos/bin/ftp -i -n -g -v

When I tried to manually try to log in to the ftp server using the
command line above:

# /usr/kerberos/bin/ftp -i -n -g -v ftp.xemacs.org

I got the following error codes:

Connected to xemacs.org.
220 ProFTPD 1.2.0pre10 Server (ProFTPD on ftp.tux.org) [gwyn.tux.org]
500 AUTH not understood.
500 AUTH not understood.
KERBEROS_V4 rejected as an authentication type
ftp>

Therefore, there appears to be a problem with the Kerberos ftp client
auto-authentication routines.

The workaround is to specify another ftp client (e.g. /usr/bin/ftp)  as
Michael Sperber <sperber@informatik.uni-tuebingen.de> suggested,

> Alternatively, use a
> non-kerberized ftp client (in our setup, /usr/bin/ftp is it) and set
> the value of `efs-ftp-program-name' to it.

...or disable auto-authentication, as Evgeny Roubinchtein
<evgenyr@cs.washington.edu> suggested


> I saw the same exact problem.  Add a "-u" to the list which is the
> value of the efs-ftp-program-args variable (either using the Customize

> facility (i.e. "M-x customize-variable efs-ftp-program-args")
(probably
> the cleanest),

or add the following to your .emacs file.

> (eval-after-load "efs"
>   '(setq efs-ftp-program-args (cons "-u" efs-ftp-program-args)))
Comment 1 Chris Evans 2000-10-15 18:42:10 EDT
Generally, the kerberized ftp client makes ftp connections look "tatty". Take a
look:
[chris@localhost chris]$ ftp ftp.lmh.ox.ac.uk
Connected to ferret.lmh.ox.ac.uk.
220 ferret.lmh.ox.ac.uk FTP server ready.
500 'AUTH GSSAPI': command not understood.
500 'AUTH KERBEROS_V4': command not understood.
KERBEROS_V4 rejected as an authentication type
Name (ftp.lmh.ox.ac.uk:chris):

The three lines in the middle really should be suppressed and not output to the
terminal.
Comment 2 Bill Nottingham 2006-08-07 15:41:58 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 3 Bill Nottingham 2006-10-18 13:00:45 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.