Bug 181863 - php-pdo conflicts
php-pdo conflicts
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
: 191695 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-17 03:58 EST by Ivan Gyurdiev
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 5.1.2-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-28 12:05:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2006-02-17 03:58:52 EST
imho conflicts should be handled by marking packages as Conflicts and Obsoletes
in rpm:

Conflicts below:
php-pdo <---> php-pecl-pdo-sqlite
php-pdo <---> php-pecl-pdo
php-devel <---> php-pecl-pdo-devel

        file /etc/php.d/pdo_sqlite.ini from install of php-pdo-5.1.2-4.3
conflicts with file from package php-pecl-pdo-sqlite-0.3-3.fc5
        file /usr/lib64/php/modules/pdo_sqlite.so from install of
php-pdo-5.1.2-4.3 conflicts with file from package php-pecl-pdo-sqlite-0.3-3.fc5
        file /etc/php.d/pdo.ini from install of php-pdo-5.1.2-4.3 conflicts with
file from package php-pecl-pdo-1.0.2-1.fc5
        file /usr/lib64/php/modules/pdo.so from install of php-pdo-5.1.2-4.3
conflicts with file from package php-pecl-pdo-1.0.2-1.fc5
        file /usr/include/php/ext/pdo/php_pdo.h from install of
php-devel-5.1.2-4.3 conflicts with file from package php-pecl-pdo-devel-1.0.2-1.fc5
        file /usr/include/php/ext/pdo/php_pdo_driver.h from install of
php-devel-5.1.2-4.3 conflicts with file from package php-pecl-pdo-devel-1.0.2-1.fc5
Comment 1 Joe Orton 2006-02-28 12:05:57 EST
Makes sense, thanks for the report.
Comment 2 Joe Orton 2006-05-16 11:26:19 EDT
*** Bug 191695 has been marked as a duplicate of this bug. ***
Comment 3 Matthias Saou 2006-05-16 11:37:02 EDT
Someone should have CC'ed me in order to get the Extras packages deleted! :-)
I'll be doing that now.

Note You need to log in before you can comment on or make changes to this bug.