Bug 181913 - [x86_64] excessive debug messages kill 3D performance for i945G
[x86_64] excessive debug messages kill 3D performance for i945G
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
: Desktop
: 158016 (view as bug list)
Depends On:
Blocks: 181409
  Show dependency treegraph
 
Reported: 2006-02-17 13:48 EST by John W. Lockhart
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2006-0412
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 17:44:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John W. Lockhart 2006-02-17 13:48:36 EST
Description of problem:
When the i915 kernel module is present, Xorg turns on 3D features;
but this generates debug messages in mesa.  This turns glxgears
performance down to about 22fps from about 1000fps (accelerated)
or 800fps (unaccelerated).

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-1.EL.13.25

How reproducible:
Install xorg-x11 and related rpms, then boot with an x86_64 kernel
that has the i915 drm module.  Run glxgears from a terminal
and observe the spew.  Redirect stderr to /dev/null, hiding
the spew, and see the very low performance numbers... 
 
Actual results:

Debugging spew and awful 3D performance

Expected results:

No messages on stderr in the absense of errors,
and respectable 3D performance.

Additional info:
This issue was first raised in RHEL4-U3.  Xorg is covered
in bug 170517, and the kernel in 173882.

A patch exists here:
https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=124724

Kernel support for i915 under x86_64 needs to be added to trigger
this problem; bug 181912 covers that issue.
Comment 3 Mike A. Harris 2006-03-21 13:31:57 EST
*** Bug 158016 has been marked as a duplicate of this bug. ***
Comment 5 Mike A. Harris 2006-03-28 13:01:42 EST
Patch xorg-x11-6.8.2-mesa-i915-squelch-debug-spew.patch added to test
candidate for U4.

Please test the xorg-x11-6.8.2-1.EL.13.26 packages available for download via
FTP at:  ftp://people.redhat.com/mharris/testing/4E/xorg-x11
Comment 10 Mike A. Harris 2006-04-25 10:17:49 EDT
Setting bug to MODIFIED state as per comment #5
Comment 18 Red Hat Bugzilla 2006-08-10 17:44:55 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0412.html

Note You need to log in before you can comment on or make changes to this bug.