Bug 181930 - IBM JVM cxia32142-20050609 crashes Java Exception
IBM JVM cxia32142-20050609 crashes Java Exception
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: java-1.4.2-ibm (Show other bugs)
3.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Thomas Fitzsimmons
:
: 181932 (view as bug list)
Depends On:
Blocks: 170417
  Show dependency treegraph
 
Reported: 2006-02-17 15:18 EST by David Bennett
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2006-0747
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-01 08:47:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Gzipped java core from NullPointerException throwing Signal 11 (53.11 KB, application/octet-stream)
2006-02-17 15:18 EST, David Bennett
no flags Details
Gzipped java core from IOException throwing Signal 11 (53.11 KB, application/octet-stream)
2006-02-17 15:23 EST, David Bennett
no flags Details
Gzipped java core from NullPointerException throwing Signal 11 (53.18 KB, application/octet-stream)
2006-02-18 01:04 EST, David Bennett
no flags Details
Gzipped java core from IOException throwing Signal 11 (50.37 KB, application/octet-stream)
2006-02-18 01:06 EST, David Bennett
no flags Details

  None (edit)
Description David Bennett 2006-02-17 15:18:08 EST
Description of problem:

On a Tomcat web application running on the IBM JVM, the JVM crashes with 
SIGSEGV occasionally when an Exception is thrown by a Servlet or JSP for to 
the application server for processing.  

Dump file reports:

1HPSIGRECV     SIGSEGV received in ?? at 0xffffffff in ??. Processing 
terminated.
1HPFULLVERSION J2RE 1.4.2 IBM build cxia32142-20050609

It appears as though the instruction pointer (EIP) is being corrupted:

1HPTHDDETAILS  Current Thread Details
NULL           ----------------------
NULL
3HPREGISTERS           Register Values
NULL                   ---------------
3HPREGVALUES            EAX : 00000000, EBX : B369522C, ECX : B2364B78
3HPREGVALUES            EDX : B42A5EE8, ESI : B44E9520, EDI : B3694E00
3HPREGVALUES            EBP : 086668E0, ESP : B3694EE0, EIP : FFFFFFFF
3HPREGVALUES            EFLAGS : 00010292
NULL
3HPNATIVESTACK         Native Stack of "http-127.0.0.1-8080-Processor4" PID 
2842
NULL                   -------------------------
3HPSTACKLINE            FFFFFFFF
NULL

Version-Release number of selected component (if applicable):

  IBM JVM cxia32142-20050609 
  java-1.4.2-ibm-devel-1.4.2.2-1jpp_9rh

How reproducible:

This has occured when processing a NullPointerException and also an 
IOException due to a directory permission problem.

Other environments running the same application under heavier load do not 
exhibit the problem.

Additional info:
  See javacores attached.
Comment 1 David Bennett 2006-02-17 15:18:08 EST
Created attachment 124830 [details]
Gzipped java core from NullPointerException throwing Signal 11
Comment 2 David Bennett 2006-02-17 15:21:53 EST
*** Bug 181932 has been marked as a duplicate of this bug. ***
Comment 3 David Bennett 2006-02-17 15:23:01 EST
Created attachment 124831 [details]
Gzipped java core from IOException throwing Signal 11
Comment 4 David Bennett 2006-02-18 01:04:23 EST
Created attachment 124847 [details]
Gzipped java core from NullPointerException throwing Signal 11 

Gzipped java core from NullPointerException throwing Signal 11
Comment 5 David Bennett 2006-02-18 01:06:33 EST
Created attachment 124850 [details]
Gzipped java core from IOException throwing Signal 11 

This Signal 11 occured during normal processing of an IOException.  The
exception was a permission issue regarding a file write, However,  the Tomcat
applications error handler defined in WEB-INF/web.xml was not called.  Instead
this strange Signal 11 occured.
Comment 8 Thomas Fitzsimmons 2006-11-24 14:12:09 EST
Mark, has IBM seen this problem before?  Do you know if it has been fixed in the
1.4.2 SR6 release?
Comment 11 Red Hat Bugzilla 2006-12-01 08:47:23 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0747.html

Note You need to log in before you can comment on or make changes to this bug.