Bug 181932 - IBM JVM cxia32142-20050609 crashes Java Exception
IBM JVM cxia32142-20050609 crashes Java Exception
Status: CLOSED DUPLICATE of bug 181930
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: java-1.4.2-ibm (Show other bugs)
3.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Thomas Fitzsimmons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-17 15:19 EST by David Bennett
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-17 15:21:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Bennett 2006-02-17 15:19:13 EST
Description of problem:

On a Tomcat web application running on the IBM JVM, the JVM crashes with 
SIGSEGV occasionally when an Exception is thrown by a Servlet or JSP for to 
the application server for processing.  

Dump file reports:

1HPSIGRECV     SIGSEGV received in ?? at 0xffffffff in ??. Processing 
terminated.
1HPFULLVERSION J2RE 1.4.2 IBM build cxia32142-20050609

It appears as though the instruction pointer (EIP) is being corrupted:

1HPTHDDETAILS  Current Thread Details
NULL           ----------------------
NULL
3HPREGISTERS           Register Values
NULL                   ---------------
3HPREGVALUES            EAX : 00000000, EBX : B369522C, ECX : B2364B78
3HPREGVALUES            EDX : B42A5EE8, ESI : B44E9520, EDI : B3694E00
3HPREGVALUES            EBP : 086668E0, ESP : B3694EE0, EIP : FFFFFFFF
3HPREGVALUES            EFLAGS : 00010292
NULL
3HPNATIVESTACK         Native Stack of "http-127.0.0.1-8080-Processor4" PID 
2842
NULL                   -------------------------
3HPSTACKLINE            FFFFFFFF
NULL

Version-Release number of selected component (if applicable):

  IBM JVM cxia32142-20050609 
  java-1.4.2-ibm-devel-1.4.2.2-1jpp_9rh

How reproducible:

This has occured when processing a NullPointerException and also an 
IOException due to a directory permission problem.

Other environments running the same application under heavier load do not 
exhibit the problem.

Additional info:
  See javacores attached.
Comment 1 David Bennett 2006-02-17 15:21:46 EST
Bugzilla threw product error when posting.

*** This bug has been marked as a duplicate of 181930 ***

Note You need to log in before you can comment on or make changes to this bug.