Bug 181935 - Problem fetching Red Hat bugzilla Icon
Problem fetching Red Hat bugzilla Icon
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: eclipse-bugzilla (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-17 15:25 EST by Igor Foox
Modified: 2013-04-02 00:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-11 10:26:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Igor Foox 2006-02-17 15:25:28 EST
Description of problem:
There is a problem when fetching the favicon for the Red Hat bugzilla, this
happens only with GCJ. The slowdown is not in the actual fetching of the icon,
but seems to happen in one of the Listeners that get notified of the event

Version-Release number of selected component (if applicable):
0.2.2-2

How reproducible:
Always.

Steps to Reproduce:
1.Open the Bug Systems view.  
2.Right click, select Add Bug System. Add the Red Hat bugzilla specifically from
the drop down selection list.
3.Click Finish.
  
Actual results:
The UI hangs for a minute or so.

Expected results:
UI should not hang, icon fetching should not take more than a few seconds.

Additional info:
Comment 1 Andrew Overholt 2006-02-17 16:39:26 EST
I've tracked this down to an issue in AbstractTreeViewer and StructuredViewer
(both in org.eclipse.jfact.viewers).  In AbstractTreeViewer.createTreeItem, a
call is made to StructuredViewer.updateItem.  This updateItem call is taking a
very long time when item = TreeItem {Red Hat 
[https://bugzilla.redhat.com/bugzilla]} but not when item = TreeItem {Apache 
[http://issues.apache.org/bugzilla/]}.  I don't know why ...

More concerning to me is that we're somehow ending up in parts of JFace that say
"EXPERIMENTAL.  Not to be used except by JDT."  The call hierarchy in our case
looks like this:

AbstractTreeViewer.internalRefresh(Widget, Object, boolean, boolean)
AbstractTreeViewer.internalRefresh(Object, boolean)
StructuredViewer.preservingSelection
StructuredViewer.refresh(final Object element)
TreeViewer.refresh(Object)
TreeManager.elementsAdded
BugViewListener.elementsAdded
EventHandler.elementsAdded
Providers.getInstance.addProvider
AddBugzillaWizard.performFinish

I wonder if we're somehow using TreeViewer incorrectly.  An interesting
experiment would be to see how this performs on 3.2

Performance numbers:

Sun:  ~3 seconds for adding both Apache and Red Hat bugzillas
gij:  ~4 seconds for adding Apache, ~65 seconds for adding Red Hat (interpreted)
Comment 2 Red Hat Bugzilla 2007-09-11 00:05:23 EDT
User klee@redhat.com's account has been closed
Comment 3 Andrew Overholt 2007-09-11 10:26:21 EDT
We are now shipping Mylyn which obsoletes the old bugzilla plugin.  Please open
a request at bugs.eclipse.org against Mylyn if this issue persists.  Thank you.

Note You need to log in before you can comment on or make changes to this bug.