Bug 181981 - WindowMaker-0.92-4 is not functional
WindowMaker-0.92-4 is not functional
Product: Fedora
Classification: Fedora
Component: WindowMaker (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2006-02-18 05:27 EST by Andrew Zabolotny
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-03-02 09:32:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Andrew Zabolotny 2006-02-18 05:27:49 EST
Description of problem:
After installing WindowMaker any attempt to run it results in a WindowMaker
crash dialog.

Version-Release number of selected component (if applicable):

How reproducible:
Always, if locale is not C (I tried at least several locales).

Steps to Reproduce:
1. Install WindowMaker-0.92-4
2. In GDM login window choose WindowMaker session
3. Login
Actual results:

Expected results:
Work :)

Additional info:
0.92-fc3 rpm package used to work. But in general, the best WindowMaker package
I've ever seen is the one from ALTLinux, since WindowMaker is actually used by
many ALTLinux developers. They both made and collected a lot of good patches,
including a patch that allows using encodings other than UTF-8.

I kind of ported their SRPM to Fedora Core (ALTLinux is based on Mandrake so has
incompatible .spec file). I've put it here:
http://cs.ozerki.net/zap/WindowMaker-0.92.0-zap.src.rpm in the case somebody is
interested. Or you can look at ALTLinux SRPM directly.
Comment 1 Andreas Bierfert 2006-02-20 02:58:14 EST
I can reproduce this on my laptop (did not use it since the rebuild). I will see
what I can do to get it running again and see what patches would be nice to
integrate. Thanks for the suggestions.
Comment 2 Andreas Bierfert 2006-02-27 07:17:03 EST
Ok I finally found time to look at this and fix it:

I have set up a package with must fixes that are in the ALTLinux SRPM as I like
most of them a lot. Problem is still the coredump which is caused by gcc4.1
stack protector stuff. I will see if I can find a fix or workaround and then you
can enjoy the FE WindowMaker just like the ALTLinux one =)
Comment 3 Andreas Bierfert 2006-03-02 09:32:48 EST
Fixed and pushed.

Note You need to log in before you can comment on or make changes to this bug.