Bug 182019 - Cannot set screen resolution to 1600x1200
Cannot set screen resolution to 1600x1200
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-19 01:39 EST by Dawid Zamirski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-24 07:41:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (2.60 KB, text/plain)
2006-02-19 01:39 EST, Dawid Zamirski
no flags Details
Xorg Log (46.05 KB, text/plain)
2006-02-19 01:39 EST, Dawid Zamirski
no flags Details

  None (edit)
Description Dawid Zamirski 2006-02-19 01:39:01 EST
Description of problem:
I have a LCD monitor (Samsung SyncMater 214T) whose native resolution is
1600x1200. In system-config-display I've selected the monitor model as Samsung
SyncMaster 213T (same native resolution & screen size - works fine in FC4), my
video card which is GeForce 6800GT and set the resolution to 1600x1200 in 24bit
color depth. After reboot (during graphical boot) the screen is set to some
lower resolution (looks like 1280x1024) with the virtual screen larger than the
screen itself. After logging in into GNOME I launched gnome-display-properties
to set the screen to 1600x1200 but the highest available resolution is 1280x960
although system-config-display is set to 1600x1200 mode.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.0.1-6.1

How reproducible:
Always

Steps to Reproduce:
1. Set the screen resolution to 1600x1200 or higher in system-config-display
2. Login to GNOME (starts with some panoramic res instead of what was set in s-c-d)
3. System => Preferences => Screen Resolution doesn't allow to get higher than
1280x960
  
Actual results:
Improper (non native) screen resolution

Expected results:
System => Preferences => Screen Resolution should show all supported resolutions
up to what was set in stystem-config-display

Additional info:
FC4 installation works fine with the settings Imentioned indescription.
Disabling SELinux doesn't help either :-) I've attached my xorg.conf and logs
Comment 1 Dawid Zamirski 2006-02-19 01:39:01 EST
Created attachment 124859 [details]
xorg.conf
Comment 2 Dawid Zamirski 2006-02-19 01:39:54 EST
Created attachment 124860 [details]
Xorg Log
Comment 3 Ignacio Vazquez-Abrams 2006-02-19 01:42:43 EST
(In reply to comment #2)
> Created an attachment (id=124860) [edit]
> Xorg Log

"(II) NV(0): Not using mode "1600x1200" (no mode of this name)"
Comment 4 Mike A. Harris 2006-02-20 07:15:53 EST
(II) NV(0): Mode "1600x1200" is larger than BIOS programmed panel size of 1280 x
1024.  Removing.
(II) NV(0): Not using default mode "1600x1200" (unknown reason)


It appears this is caused due to a BIOS bug, or due to a bug in the nv
driver probing the panel size from the BIOS.  

Please report this issue to X.Org developers by filing a bug report in
the X.Org bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "NEEDINFO_REPORTER", awaiting X.Org bug URL
for tracking.
Comment 5 Dawid Zamirski 2006-02-22 19:16:46 EST
Ok I finally got a time to handle this :-) 
I found the same bug already reported on the Xorg's bugzilla (
https://bugs.freedesktop.org/show_bug.cgi?id=4314 ) therefore I didn't create a
new one as it would be a duplicate. The same issue seems to affect FC4 + updates
- I haven't noticed it earlier because I was using proprietary 'nvidia' driver.
I cannot tell whether it happened in a 'plain' FC4 (without updates) because I
got my monitor about 2 months ago, so my installation was already patched.
Comment 6 Mike A. Harris 2006-02-24 07:41:03 EST
Thanks for the URL.  Tracking upstream in X.Org bugzilla.


Note You need to log in before you can comment on or make changes to this bug.