Bug 182048 - HAL assigns different mount point names to USB devices if device attached at boot time.
HAL assigns different mount point names to USB devices if device attached at ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-volume-manager (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-19 14:02 EST by William Shotts
Modified: 2013-03-13 00:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 16:08:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Shotts 2006-02-19 14:02:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060210 Fedora/1.5.0.1-3 Firefox/1.5.0.1

Description of problem:
If a USB device is attached at boot time, its mount point name is based on some variation of "disk", but if the device is hot plugged, the mount point name is based on the volumne name.  This is inconsistent.

Version-Release number of selected component (if applicable):
hal-0.5.7-0.cvs20060213.1

How reproducible:
Always

Steps to Reproduce:
1. Attach USB devices to a running system.  Note names of mount points in /media
2. Reboot system leaving devices attached
3. Observe mount point names after reboot
  

Actual Results:  Devices are named according to a different scheme.  No longer uses volume names for basis of mount point names.

Expected Results:  A consistent naming scheme should be used.

Additional info:
Comment 1 William Shotts 2006-02-19 16:02:23 EST
Upon further examination, I see this is only observed in Nautilus.  If a device
is present at start up, it has the "disk" style naming, but once it is unmounted
and re-mounted by Nautilus it assumes the volume name style naming.  In KDE this
does not happen - it always has "disk" style naming.  That being said, this does
not apply to ext3 formatted file systems that are on removable devices.  They
always have volume name style mount points.  Very inconsistent and confusing.
Comment 2 David Zeuthen 2006-02-20 12:22:07 EST
I can't reproduce this on my system. Maybe you have old entries in /etc/fstab;
care to paste the output of /etc/fstab?
Comment 3 William Shotts 2006-02-20 12:36:47 EST
Sure.

[bshotts@twin7 ~]$ cat /etc/fstab
LABEL=/                 /                       ext3    defaults        1 1
LABEL=/boot1            /boot                   ext3    defaults        1 2
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
LABEL=/home             /home                   ext3    defaults        1 2
proc                    /proc                   proc    defaults        0 0
sysfs                   /sys                    sysfs   defaults        0 0
LABEL=SWAP-hda3         swap                    swap    defaults        0 0
Comment 4 David Zeuthen 2006-02-20 12:49:23 EST
This looks like a gnome-volume-manager issue so I'm reassigning.. 

Try this:

 1. log in to GNOME
 2. unmount your USB device via nautilus
 3. open a terminal
 4. do a 'gnome-session-remove gnome-volume-manager'
 5. do 'gnome-volume-manager --sm-disable --no-daemon'

Post the output from 5. For me I get this line

 manager.c/2699: mount_all: mounting /dev/sda1
 manager.c/1562: mounting
/org/freedesktop/Hal/devices/volume_uuid_d093dcb9_a16a_47ef_a04f_c75f546aeee5...
 manager.c/774: executing command: /usr/bin/gnome-mount --no-ui
--hal-udi=/org/freedesktop/Hal/devices/volume_uuid_d093dcb9_a16a_47ef_a04f_c75f546aeee5
 manager.c/2380: Mounted:
/org/freedesktop/Hal/devices/volume_uuid_d093dcb9_a16a_47ef_a04f_c75f546aeee5

Is your device mounted in the right location?
Comment 5 William Shotts 2006-02-21 13:57:51 EST
[bshotts@twin7 ~]$ gnome-volume-manager --sm-disable --no-daemon
manager.c/583: setting[0]: bool: autobrowse = 1
manager.c/583: setting[1]: bool: autoburn = 0
manager.c/578: setting[2]: string: autoburn_audio_cd_command = nautilus
--no-desktop burn:
manager.c/578: setting[3]: string: autoburn_data_cd_command = nautilus
--no-desktop burn:
manager.c/583: setting[4]: bool: autoipod = 0
manager.c/578: setting[5]: string: autoipod_command =
manager.c/583: setting[6]: bool: autokeyboard = 0
manager.c/578: setting[7]: string: autokeyboard_command =
manager.c/583: setting[8]: bool: automount_drives = 1
manager.c/583: setting[9]: bool: automount_media = 1
manager.c/583: setting[10]: bool: automouse = 0
manager.c/578: setting[11]: string: automouse_command =
manager.c/583: setting[12]: bool: autophoto = 0
manager.c/578: setting[13]: string: autophoto_command = gthumb-import %h
manager.c/583: setting[14]: bool: autopalmsync = 0
manager.c/578: setting[15]: string: autopalmsync_command = gpilotd-control-applet
manager.c/583: setting[16]: bool: autoplay_cda = 1
manager.c/578: setting[17]: string: autoplay_cda_command = totem %d
manager.c/583: setting[18]: bool: autoplay_dvd = 1
manager.c/578: setting[19]: string: autoplay_dvd_command = totem %d
manager.c/583: setting[20]: bool: autoplay_vcd = 1
manager.c/578: setting[21]: string: autoplay_vcd_command = totem %d
manager.c/583: setting[22]: bool: autopocketpc = 0
manager.c/578: setting[23]: string: autopocketpc_command = multisync
manager.c/583: setting[24]: bool: autoprinter = 0
manager.c/578: setting[25]: string: autoprinter_command =
manager.c/583: setting[26]: bool: autorun = 0
manager.c/578: setting[27]: string: autorun_path = .autorun:autorun:autorun.sh
manager.c/583: setting[28]: bool: autotablet = 0
manager.c/578: setting[29]: string: autotablet_command =
manager.c/2365: mount_all: mounting /dev/sda1
manager.c/1298: mounting /org/freedesktop/Hal/devices/volume_uuid_2C12_B46D...
manager.c/717: executing command: /usr/bin/gnome-mount --no-ui
--hal-udi=/org/freedesktop/Hal/devices/volume_uuid_2C12_B46D
manager.c/2082: Mounted: /org/freedesktop/Hal/devices/volume_uuid_2C12_B46D
Comment 6 David Zeuthen 2006-02-21 14:40:38 EST
In response to comment 5: is your device mounted in the right location?
Comment 7 William Shotts 2006-02-21 15:01:24 EST
I think I see what the problem is now.  This makes my head hurt.  Ok, from the
beginning...

I am normally a KDE user but look at GNOME sometimes while testing, so I switch
back and forth a lot.

I a bunch of different USB device for testing but for this test I am limiting it
to a vfat formatted 8Gb disk drive in a USB 2.0 enclosure.

If I attach the drive while KDE is running, it mounts it on /media/disk.
If I attach the drive while GNOME is running, it mounts it on /media/NEW VOLUME.
That's bug number one - they are not consistent.

If I leave the drive attached and log out of either KDE or GNOME, the drive
remains mounted.  I think those are bugs and have filed them separately.

If I attatch the drive in KDE, log out and log into GNOME, GNOME shows the drive
and the mount point remains /media/disk as KDE created it, but if I unmount the
drive in GNOME and then remount it, the mount point changes to /media/NEW
VOLUME.  So that's why it appears to change.  KDE and GNOME are using different
names for the mount points and the drives remain mounted after the attaching
user has logged off.
Comment 8 David Zeuthen 2006-02-21 16:08:16 EST
> KDE and GNOME are using different names for the mount points

Not a bug.

> and the drives remain mounted after the attaching user has logged off.

Not a bug in GNOME at least.

Closing as NOTABUG. Thanks for your input anyway.

Note You need to log in before you can comment on or make changes to this bug.