Bug 182051 - cal crashes when TERM=dumb
cal crashes when TERM=dumb
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-19 15:36 EST by Will Partain
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-20 09:35:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Will Partain 2006-02-19 15:36:05 EST
Description of problem:
on a fully-patched x86_64 FC4 box, with TERM envvar as 'dumb', /usr/bin/cal
crashes (seg fault)

Version-Release number of selected component (if applicable):
util-linux-2.12p-9.13

How reproducible:
always (but it seems new behavior to me...)

Steps to Reproduce:
1. in an xterm, export TERM=dumb
2. /usr/bin/cal (crashes)
3. export TERM=xterm
4. /usr/bin/cal (works as expected)

Actual results:


Expected results:


Additional info: I found this when I tried to run 'cal' in an xemacs shell
buffer (where TERM happened to be 'dumb').  I think this used to work.
Comment 1 Will Partain 2006-02-20 07:25:10 EST
1. Incidentally, in the logs, I got "Feb 19 20:26:53 albus kernel: cal[10036]
general protection rip:40162a rsp:7fffffbc7ce8 error:0" each time

2. It's working today!  Same xemacs shell, same everything.  Machine was not
under stress at either time.  So am entirely baffied...
Comment 2 Karel Zak 2006-02-20 09:35:40 EST
# TERM=dumb cal
   February 2006
Su Mo Tu We Th Fr Sa
          1  2  3  4
 5  6  7  8  9 10 11
12 13 14 15 16 17 18
192 21 22 23 24 25
26 27 28

# rpm -qf /usr/bin/cal
util-linux-2.12p-9.13

I'm not able to reproduce this bug. Please, reopen the this report if you will
have more information or the problem will be presistent. Thnaks.

Note You need to log in before you can comment on or make changes to this bug.