Bug 182053 - HAL should be consistent regarding use of "sync" option
HAL should be consistent regarding use of "sync" option
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-19 16:12 EST by William Shotts
Modified: 2013-03-13 00:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-20 10:47:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Shotts 2006-02-19 16:12:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060210 Fedora/1.5.0.1-3 Firefox/1.5.0.1

Description of problem:
For removable USB storage devices, HAL mounts ext3 file systems with the sync option but does not apply the sync option on vfat file systems.  I think that the use of sync would be desirable for any removable device that supported it.

Version-Release number of selected component (if applicable):
hal-0.5.7-0.cvs20060213.1

How reproducible:
Always

Steps to Reproduce:
1. Attach USB storage devices with vfat and ext3 file systems.
2. Observe mount options used
3.
  

Actual Results:  Output from mount:

/dev/sdb1 on /media/disk-1 type vfat (rw,noexec,nosuid,nodev,shortname=winnt,uid=500)
/dev/sda1 on /media/usb-ext3 type ext3 (rw,noexec,nosuid,nodev,sync)

Expected Results:  Both devices should be mounted with sync option since both file systems support it.

Additional info:
Comment 1 John (J5) Palmieri 2006-02-20 10:47:45 EST
On an vfat file system mounting sync is a quick way to make sure your USB memory
stick desn't last very long.  This is because the FAT table which resides in the
same place on the the device is updated on every write.  Since flash memory can
only be written to a finite number of times the FAT will die an order of
magnatude faster than the actuall data on the disk.  Writting async greatly
improves the life of the device.

Note You need to log in before you can comment on or make changes to this bug.