Bug 182056 - HAL leaves user-mounted removeable media mounted after user logs off
HAL leaves user-mounted removeable media mounted after user logs off
Status: CLOSED DUPLICATE of bug 182092
Product: Fedora
Classification: Fedora
Component: gnome-mount (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-19 16:44 EST by William Shotts
Modified: 2013-03-13 00:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-22 08:47:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description William Shotts 2006-02-19 16:44:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060210 Fedora/1.5.0.1-3 Firefox/1.5.0.1

Description of problem:
If a user attaches a USB storage device (say a pen drive) the device is automatically mounted.  If the user then logs off, the device is not unmounted.  I see this being a danger in that a user might assume that if he logs off, he/she could just pull the pen drive out.

Version-Release number of selected component (if applicable):
hal-0.5.7-0.cvs20060213.1

How reproducible:
Always

Steps to Reproduce:
1. Attach a USB storage device while logged in as a user.
2. Log out
3. At the login screen press Ctl-Alt-F1 and log in as root.  Type "mount"
  

Actual Results:  Removable storage volumes remain mounted.

Expected Results:  Removable storage volumes shuld have been unmounted when the user who mounted them logged out.

Additional info:
Comment 1 Ignacio Vazquez-Abrams 2006-02-20 00:55:00 EST
hal isn't responsible for mounting/unmounting volumes, so this bug is filed in
the wrong component. Please file a bug against gnome-volume-manager and/or
whatever KDE package handles automounting instead.
Comment 2 William Shotts 2006-02-20 08:25:09 EST
Refiling for component gnome-mount
Comment 3 William Shotts 2006-02-22 08:47:34 EST

*** This bug has been marked as a duplicate of 182092 ***

Note You need to log in before you can comment on or make changes to this bug.