Bug 18206 - locking problems
locking problems
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-03 07:39 EDT by barthek
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-22 04:37:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description barthek 2000-10-03 07:39:50 EDT
Hello,

Ive been having problems with samba lately.
What I find in log.smb is:

[2000/10/03 13:31:18, 0] locking/shmem_sysv.c:sysv_shm_open(663)
  Can't create or use IPC area. Error was File exists
[2000/10/03 13:31:18, 0] locking/locking.c:locking_init(174)
  ERROR: Failed to initialise share modes

relevant info:
glibc 2.1.3-21
samba 2.0.5a-12 (I also tried 2.0.7 with same effect)

I think that the problems has begun after upgrading libc, although I am 
not willing to do a downgrade at the moment...

regards,
Comment 1 Henri Schlereth 2001-01-21 10:25:13 EST
Has there been any improvement/changes?
Comment 2 barthek 2001-01-22 04:37:30 EST
I've found the cause of this behaviour! It was not the glibc upgrade, but 
rather kernel patch from the Openwall project (clearing shared memory segments 
option). Hope this helps somebody else :>
Comment 3 Henri Schlereth 2001-01-22 11:04:11 EST
Thank you. Not a samba bug.

Note You need to log in before you can comment on or make changes to this bug.