Bug 182060 - netpbm hasn't been updated to detect the "ms bmp" format
Summary: netpbm hasn't been updated to detect the "ms bmp" format
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: netpbm (Show other bugs)
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-20 00:45 UTC by Dimitris
Modified: 2013-07-02 23:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-18 12:25:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix detection of BMP files (325 bytes, patch)
2006-02-20 00:45 UTC, Dimitris
no flags Details | Diff

Description Dimitris 2006-02-20 00:45:46 UTC
Description of problem:

the commmand line tool "anytopnm" uses the "file" command to detect types of
files. The "file" command at some point was changed to distinguish between "BMP"
and "MS BMP" file formats.

the commmand line tool "anytopnm" isn't prepared for the "MS BMP" string that
"file" returns, thus it terminates with an unknown file type error.

the anytopnm script needs to be updated in order to expect both "BMP" and "MS
BMP" strings as returned by "file" since it supports both types of bitmaps.


Version-Release number of selected component (if applicable):

netpbm-10.31-1.FC4.2


How reproducible:

always

Steps to Reproduce:
1. create an image in Microsoft Paint (Windows XP), save it to BMP
2. try to use anytopnm to convert the resulting BMP

  
Actual results:

anytopnm fails


Expected results:

anytopnm should convert the file, since it supports the format.


Additional info:

patch attached.

Comment 1 Dimitris 2006-02-20 00:45:46 UTC
Created attachment 124872 [details]
patch to fix detection of BMP files

Comment 2 Jindrich Novy 2006-02-20 12:48:19 UTC
It's now fixed since netpbm-10.31-5 in devel. An update will be pushed when more
fixes are gathered. Thanks.

Comment 3 Dimitris 2006-02-21 13:44:11 UTC
Thank you, much appriciated.


Comment 4 Dimitris 2006-04-06 21:59:23 UTC
Problem exists in Fedora Core 5:

netpbm-10.31-4
netpbm-progs-10.31-4


Comment 5 Jindrich Novy 2006-04-18 12:25:09 UTC
It's now resolved by netpbm-10.33.

Comment 6 Dimitris 2006-04-18 12:39:51 UTC
Indeed, thank you for the help, much appriciated.


Note You need to log in before you can comment on or make changes to this bug.