Bug 182072 - "help' command doesn't work in mysql interactive sessions on FC4
"help' command doesn't work in mysql interactive sessions on FC4
Status: CLOSED DUPLICATE of bug 182073
Product: Fedora
Classification: Fedora
Component: mysql (Show other bugs)
4
All Linux
medium Severity high
: ---
: ---
Assigned To: Tom Lane
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-20 02:31 EST by Robinson Tiemuqinke
Modified: 2013-07-02 23:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-20 02:33:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robinson Tiemuqinke 2006-02-20 02:31:12 EST
Description of problem:
 can not run 'help *' commands in the mysql interactive sessions.

Version-Release number of selected component (if applicable):
mysql-4.1.16-1.FC4.1, kernel-2.6.15-1.1831_FC4

How reproducible:
happens every time. 

Steps to Reproduce:
1. login in mysqld runing on localhost, FC4 with latest mysql updates.
2. run 'help' will show a menu, but then when run 'mysql contents' or 'mysql 
<any_command>', it fails.
3.
  
Actual results:



mysql> help contents

Nothing found
Please try to run 'help contents' for a list of all accessible topics

mysql> help grant

Nothing found
Please try to run 'help contents' for a list of all accessible topics

mysql> 

Expected results:
mysql> help contents
You asked for help about help category: "Contents"
For more information, type 'help <item>', where item is one of the following
categories:
   Administration
   Column Types
   Data Definition
   Data Manipulation
   Functions
   Geographic features
   Transactions

mysql> help grants
Name: 'SHOW'
Description:

SHOW has many forms that provide information about databases,
tables, columns, or status information about the server.
This section describes those following:

SHOW [FULL] COLUMNS FROM tbl_name [FROM db_name] [LIKE 'pattern']
SHOW CREATE DATABASE db_name
SHOW CREATE TABLE tbl_name
SHOW DATABASES [LIKE 'pattern']
SHOW [STORAGE] ENGINES
SHOW ERRORS [LIMIT [offset,] row_count]
SHOW GRANTS FOR user
SHOW INDEX FROM tbl_name [FROM db_name]
SHOW INNODB STATUS
SHOW [BDB] LOGS
SHOW PRIVILEGES
SHOW [FULL] PROCESSLIST
SHOW STATUS [LIKE 'pattern']
SHOW TABLE STATUS [FROM db_name] [LIKE 'pattern']
SHOW [OPEN] TABLES [FROM db_name] [LIKE 'pattern']
SHOW [GLOBAL | SESSION] VARIABLES [LIKE 'pattern']
SHOW WARNINGS [LIMIT [offset,] row_count]

If the syntax for a given SHOW statement includes a LIKE
'pattern' part, 'pattern' is a string that can contain the SQL %
and _ wildcard characters.
The pattern is useful for restricting statement output to matching values.

mysql> 

Additional info:

 I have all the mysql related packages installed on my FC4 box, and all 
packages are upgraded to cutting-edge.

  Do I have to install MySQL-share and MySQL-compact packages from 
www.mysql.com to see the help messages? Are there any confilction between 
Mysql.com's mysql packages and Redhat's mysql pacakges?

[root@host01 ~]# rpm -qa --queryformat '%{name}-%{version}-%{release}-%{arch}
\n' |grep -i mysql

mysqlclient10-devel-3.23.58-6-x86_64
mod_auth_mysql-2.6.1-4-x86_64
mysql-4.1.16-1.FC4.1-x86_64
mysql-4.1.16-1.FC4.1-i386
mysql-devel-4.1.16-1.FC4.1-x86_64
mysql-server-4.1.16-1.FC4.1-x86_64
mysql-bench-4.1.16-1.FC4.1-x86_64
mysqlclient10-3.23.58-6-x86_64
[root@host01 ~]#
Comment 1 Ignacio Vazquez-Abrams 2006-02-20 02:33:52 EST

*** This bug has been marked as a duplicate of 182073 ***
Comment 2 David Lawrence 2006-02-20 15:29:34 EST
*** Bug 182073 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.