Bug 182095 - Incorrect BuildRequires for kernel-hugemem
Summary: Incorrect BuildRequires for kernel-hugemem
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: cman   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Feist
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-20 15:05 UTC by Andreas Thienemann
Modified: 2009-04-16 20:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-20 22:13:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andreas Thienemann 2006-02-20 15:05:21 UTC
While trying the depsolver code from mock on cman-kernel, a problem with the
BuildRequires manifested itself.

Solving BuildDependencies on x86_64 fails, as the cman-kernel depends on
kernel-hugemem = %{kernel_version} and kernel-hugemem-devel = %{kernel_version}.

These packages are only built on i686 and thus do not exist in a x86_64 buildroot.

Enclosing the hugemem-requirements into %if %{buildhugemem} %endif should take
care of this problem.

Comment 1 Christine Caulfield 2006-02-20 15:20:55 UTC
Assign to chris, as I think he's the buildmeister.

Comment 2 Chris Feist 2006-02-20 22:13:52 UTC
Unfortunately to get cman-kernel to build properly with our build system we are
unable to use %if statements to exclude kernel-hugemem for non i686 builds. 
It's best to either setup a dummy package which provides kernel-hugemem on non
i686 builds or to remove the line from your builds.


Note You need to log in before you can comment on or make changes to this bug.