Bug 182124 - kernel won't boot, "BUG: spinlock bad magic..."
kernel won't boot, "BUG: spinlock bad magic..."
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-20 12:54 EST by Dimitris
Modified: 2015-01-04 17:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-04 18:42:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dimitris 2006-02-20 12:54:29 EST
Description of problem:

The latest kernel (kernel-2.6.15-1.1831_FC4) won't boot on our system, while the
default kernel that comes with FC4 DVD iso boots without problems
(kernel-2.6.11-1.1369_FC4).

The error reported is:

BUG: Spinlock bad magic on CPU#0, swapper/1 (Not tainted)
BUG: Spinlock lockup on CPU#0, (several garbage characters here)/0,
ffffffff80450690 (Not tainted)



Version-Release number of selected component (if applicable):

kernel-2.6.15-1.1831_FC4


How reproducible:

Always


Steps to Reproduce:
1. boot system with latest kernel
2. watch it die with the above error

  
Actual results:

It doens't boot


Expected results:

It should boot

Additional info:

system hardware is as follows:

motherboard: Sapphire PURE Innovation PI-A9RX480
cpu: AMD Athlon 64 3500+
memory: 512MB ram
drives: 2x 80gig drives in software raid

One additional detail: No linux kernel boots if "APIC" is enabled. Thus the APIC
option is disabled from the bios.
Comment 1 Dimitris 2006-02-21 09:18:27 EST
I've just tested a live CD (PCLinuxOS) with kernel 2.6.12 and that worked fine.
In addition, the 2.6.12 kernel also adds support for the internal ethernet
chipset (Marvel) which isn't supported by the default FC4 kernel.
Comment 2 Dimitris 2006-02-21 17:45:04 EST
Based on some discussions in IRC about this problem, people have been asking me
if this is an SMP system or if i'm running an SMP kernel.

No, this is NOT an SMP system, its a UP, running a single Athlon 64 3500+.

I don't believe i'm running an SMP kernel, 'yum' should have installed the
correct 2.6.15 UP kernel i believe. Here is what i've got:

# rpm -q kernel
kernel-2.6.11-1.1369_FC4
kernel-2.6.15-1.1831_FC4
Comment 3 Dimitris 2006-02-22 17:04:10 EST
I just tested another kernel, got it from the fedora/redhat ftp and its the
kernel 2.6.14-1.1656_FC4, which also boots without problems.

This leads me to believe that 2.6.15 has something specific that makes it
unbootable on this machine.
Comment 4 Dimitris 2006-02-23 08:55:51 EST
Hello? anyone reading these bug reports?
Comment 5 Dimitris 2006-02-23 20:03:32 EST
WOOOOW!!!

Apparently the .15 kernels i've been trying to use are SMP while all the others
are NOT SMP.

I've been told that redhat decided to use SMP kernels on UP systems because the
difference in performance is insignificant.

I dont know, but everyone tells me that my problem is related to the SMP being
enabled on the kernel....

Comment 6 Dave Jones 2006-02-26 23:57:55 EST
that decision has been made for FC5.  The change accidentally got backported to
the last rebase for the FC4 kernel.  The next errata will make the UP x86-64
kernel UP again.

The work-in-progress kernel at
http://people.redhat.com/davej/kernels/Fedora/FC-4/ has this fixed already.
Comment 7 Dimitris 2006-02-27 04:01:40 EST
Its alive! its alive!....     erm sorry :P

so, where was i...

ah yes,

well those work-in-progress kernels aren't any help to me, since my Marvel
ethernet chipset only works with either a .16 kernel or the -netdev kernels
someone has made from redhat. So i'll have to wait a while for either a .16
kernel or for the -netdev kernels to become non-smp.

i've been told that sk98lin has been deprecated and that a new driver (ske2 or
skge or something) will have support for the Marvel gigabit ethernet. The new
driver only exists in .16 kernels.

Thank you anyway.

Note You need to log in before you can comment on or make changes to this bug.