Bug 182127 - "show free space" in Layout options not saved
"show free space" in Layout options not saved
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mc (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-20 13:08 EST by Miloslav Trmač
Modified: 2013-07-02 19:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-08 05:10:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miloslav Trmač 2006-02-20 13:08:34 EST
F9-Nastavení-Rozložení: unset "show free space", click on "Uložit".
Restart mc, free space is shown again.  A (diff -urN) on the .mc
directory shows no changes after changing the "show free space" option
and saving the configuration.

Version-Release number of selected component (if applicable):
4.6.1a-7.2
Comment 1 Jindrich Novy 2006-02-28 06:24:29 EST
Fixed in mc-4.6.1a-9. Thanks.
Comment 2 Fedora Update System 2006-03-07 11:37:27 EST
From User-Agent: XML-RPC

mc-4.6.1a-5.fc4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 3 Leonard den Ottolander 2006-03-07 19:21:56 EST
Almost ;-) . State is now also saved on "Ok".

O, and please

-+	if (panel->active)
-+	    attrset (REVERSE_COLOR);
 +	addstr (tmp);
-+	attrset (NORMAL_COLOR);

Thanks :-) .
Comment 4 Jindrich Novy 2006-03-08 05:10:11 EST
(In reply to comment #3)
> Almost ;-) . State is now also saved on "Ok".

Yep, it's an upstream bug ;) Note that any of the layout options are saved
globally no matter if you choose "Ok" or "Save". Could you report me another bug
to let me fix it? I'll send patch to upstream then.

> O, and please
> 
> -+	if (panel->active)
> -+	    attrset (REVERSE_COLOR);
>  +	addstr (tmp);
> -+	attrset (NORMAL_COLOR);

I think that without it the free space widget would look inconsistent, because
the directory and "<", "v>" are drawn in REVERSE_COLOR in panels as well.

Thx for testing :)
Comment 5 Leonard den Ottolander 2006-03-08 11:19:03 EST
Wrt the saving: I should look into that then.

I find the colourization at the bottom rather distracting in contrast to the
colourization of the cwd at the top. I'm still quite capable of reading the free
space numbers in plain text without the disadvantage of being distracted by it.
Anyway, you might not want to fix it here, but I will when I apply your patch
upstream ;-) .

Note You need to log in before you can comment on or make changes to this bug.