Bug 182150 - Crash when printing a contact
Summary: Crash when printing a contact
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: evolution   
(Show other bugs)
Version: 4.0
Hardware: ppc64 Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Dave Malcolm
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords: Desktop
Depends On:
Blocks: 170416
TreeView+ depends on / blocked
 
Reported: 2006-02-20 19:59 UTC by Dave Malcolm
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-20 16:06:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dave Malcolm 2006-02-20 19:59:20 UTC
Version-Release number of selected component (if applicable):
This is on a ppc64 box:
rpm -q evolution evolution-data-server libgnomeprint22 libgnomeprintui22 pango
--queryformat "%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n"
evolution-2.0.2-27.ppc
evolution-data-server-1.0.2-9.ppc
libgnomeprint22-2.8.0-3.ppc
libgnomeprint22-2.8.0-3.ppc64
libgnomeprintui22-2.8.0-1.ppc
libgnomeprintui22-2.8.0-1.ppc64
pango-1.6.0-9.ppc
pango-1.6.0-9.ppc64


How reproducible:
100% on this box

Steps to Reproduce:
1.  Create a contact in Evolution
2.  Select the contact
3.  Select Print
4.  Print Preview

Actual results:
Segfault

(gdb)
#0  0x0f5d0e60 in pango_font_description_free () from /usr/lib/libpango-1.0.so.0
#1  0x0f5dee08 in pango_layout_set_font_description () from
/usr/lib/libpango-1.0.so.0
#2  0x0f5dee08 in pango_layout_set_font_description () from
/usr/lib/libpango-1.0.so.0
#3  0x0f5dee08 in pango_layout_set_font_description () from
/usr/lib/libpango-1.0.so.0
#4  0x0f5dee08 in pango_layout_set_font_description () from
/usr/lib/libpango-1.0.so.0
#5  0x0f5dee08 in pango_layout_set_font_description () from
/usr/lib/libpango-1.0.so.0
#6  0x0f5dee08 in pango_layout_set_font_description () from
/usr/lib/libpango-1.0.so.0
#7  0x0f5dee08 in pango_layout_set_font_description () from
/usr/lib/libpango-1.0.so.0
#8  0x0f5dee08 in pango_layout_set_font_description () from
/usr/lib/libpango-1.0.so.0
#9  0x0f5dee08 in pango_layout_set_font_description () from
/usr/lib/libpango-1.0.so.0
#10 0x0f5dee08 in pango_layout_set_font_description () from
/usr/lib/libpango-1.0.so.0
#11 0x0f5dee08 in pango_layout_set_font_description () from
/usr/lib/libpango-1.0.so.0
#12 0x0f5dee08 in pango_layout_set_font_description () from
/usr/lib/libpango-1.0.so.0
#13 0x0f5dee08 in pango_layout_set_font_description () from
/usr/lib/libpango-1.0.so.0
#14 0x0f5dee08 in pango_layout_set_font_description () from
/usr/lib/libpango-1.0.so.0
#15 0x0f5dee08 in pango_layout_set_font_description () from
/usr/lib/libpango-1.0.so.0
#16 0x0f5dee08 in pango_layout_set_font_description () from
/usr/lib/libpango-1.0.so.0
#17 0x0f5dee08 in pango_layout_set_font_description () from
/usr/lib/libpango-1.0.so.0
#18 0x0f5dee08 in pango_layout_set_font_description () from
/usr/lib/libpango-1.0.so.0
#19 0x0f5dee08 in pango_layout_set_font_description () from
/usr/lib/libpango-1.0.so.0
#20 0x0f5dee08 in pango_layout_set_font_description () from
/usr/lib/libpango-1.0.so.0
#21 0x0f5dee08 in pango_layout_set_font_description () from
/usr/lib/libpango-1.0.so.0
#22 0x0f5dee08 in pango_layout_set_font_description () from
/usr/lib/libpango-1.0.so.0
#23 0x0f5dee08 in pango_layout_set_font_description () from
/usr/lib/libpango-1.0.so.0
#24 0x0f5dee08 in pango_layout_set_font_description () from
/usr/lib/libpango-1.0.so.0
#25 0x0f5dee08 in pango_layout_set_font_description () from
/usr/lib/libpango-1.0.so.0

(looks like a corrupt stack)

Comment 1 Dave Malcolm 2006-02-20 20:06:50 UTC
Reproduced with evolution-2.0.2-22; not a regression from U2.

Comment 2 Dave Malcolm 2006-02-20 20:09:52 UTC
Works with 2.0.2-8

Comment 3 Dave Malcolm 2006-02-20 20:15:56 UTC
From ChangeLog, appears that this may have been introduced in 2.0.2-10 (port of
addressbook printing to use Pango), which I believe was first shipped in RHEL4
U2; updating metadata accordingly.

Comment 4 Dave Malcolm 2006-02-20 20:21:18 UTC
This was on a ppc64 box, running ppc evolution packages

Comment 7 RHEL Product and Program Management 2006-07-20 16:06:48 UTC
Development Management has reviewed and declined this request.  You may appeal this decision by reopening this request.


Note You need to log in before you can comment on or make changes to this bug.