Bug 182155 - cdrecord wont burn
cdrecord wont burn
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cdrtools (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-20 15:16 EST by Ingvar Hagelund
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-19 07:47:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ingvar Hagelund 2006-02-20 15:16:25 EST
Description of problem:


Version-Release number of selected component (if applicable):

cdrecord-2.01.1-9.0.FC4.1


How reproducible:

Burn a cd

Steps to Reproduce:
1. run cdrecord with suitable options
2. watch it fail, or watch the box hang completely (ide-scsi)
  
Actual results:
cdrecord fails to burn content to the cd

Expected results:
successful burned cd

Additional info:

cdrecord is ran as root on a dual athlon system with a Samsung CD/RW 40-12-40
(see below), and with cdrecord's ATA device specification. Running with ide-scsi
(dev=0,0,0), the machine hangs completely just before it should start burning.

The drive and cd batch works without problems on Windows XP.

# uname -a
Linux re 2.6.15-1.1831_FC4smp #1 SMP Tue Feb 7 13:48:31 EST 2006 i686 athlon
i386 GNU/Linux

# rpm -q cdrecord
cdrecord-2.01.1-9.0.FC4.1

# cdrecord -scanbus
Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004 Jörg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in this version.
scsidev: 'ATA'
devname: 'ATA'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version (schily - Red
Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c       1.83 04/05/20 Copyright
1997 J. Schilling').
scsibus1:
        1,0,0   100) *
        1,1,0   101) 'SAMSUNG ' 'CD-R/RW SW-240B ' 'R402' Removable CD-ROM
        1,2,0   102) *
        1,3,0   103) *
        1,4,0   104) *
        1,5,0   105) *
        1,6,0   106) *
        1,7,0   107) *

# cdrecord -tao -v -eject speed=40 driveropts=burnproof dev=ATA:1,1,0 test.iso
Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004 Jörg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in this version.
TOC Type: 1 = CD-ROM
scsidev: 'ATA:1,1,0'
devname: 'ATA'
scsibus: 1 target: 1 lun: 0
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version (schily - Red
Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c       1.83 04/05/20 Copyright
1997 J. Schilling').
Driveropts: 'burnproof'
SCSI buffer size: 64512
atapi: -1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 1
Vendor_info    : 'SAMSUNG '
Identifikation : 'CD-R/RW SW-240B '
Revision       : 'R402'
Device seems to be: Generic mmc CD-RW.
Current: 0x0009
Profile: 0x0008
Profile: 0x0009 (current)
Profile: 0x000A
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Driver flags   : MMC-2 SWABAUDIO BURNFREE FORCESPEED
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R96R
Drive buf size : 5554176 = 5424 KB
FIFO size      : 4194304 = 4096 KB
Track 01: data   516 MB
Total size:      593 MB (58:49.25) = 264694 sectors
Lout start:      594 MB (58:51/19) = 264694 sectors
Current Secsize: 2048
ATIP info from disk:
  Indicated writing power: 4
  Is not unrestricted
  Is not erasable
  Disk sub type: Medium Type A, low Beta category (A-) (2)
  ATIP start of lead in:  -12508 (97:15/17)
  ATIP start of lead out: 359845 (79:59/70)
Disk type:    Short strategy type (Phthalocyanine or similar)
Manuf. index: 22
Manufacturer: Ritek Co.
Blocks total: 359845 Blocks current: 359845 Blocks remaining: 95151
Forcespeed is OFF.
Speed set to 7056 KB/s
Starting to write CD/DVD at speed  40.0 in real TAO mode for single session.
Last chance to quit, starting real write    0 seconds. Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
BURN-Free is OFF.
Turning BURN-Free on
Performing OPC...
Starting new track at sector: 0
Track 01:    5 of  516 MB written (fifo 100%) [buf  95%]  78.5x.cdrecord:
Success. write_g1: scsi sendcmd: no error
CDB:  2A 00 00 00 0B 05 00 00 1F 00
status: 0x4 (CONDITION MET/GOOD)
resid: 63488
cmd finished after 40.108s timeout 40s

write track data: error after 5777408 bytes
cdrecord: A write error occured.
cdrecord: Please properly read the error message above.
cdrecord: Success. test unit ready: scsi sendcmd: no error
CDB:  00 00 00 00 00 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 02 00 00 00 00 0C 00 00 00 00 04 01 00 00
Sense Key: 0x2 Not Ready, Segment 0
Sense Code: 0x04 Qual 0x01 (logical unit is in process of becoming ready) Fru 0x0
Sense flags: Blk 0 (not valid)
cmd finished after 0.000s timeout 40s
cdrecord: Success. flush cache: scsi sendcmd: no error
CDB:  35 00 00 00 00 00 00 00 00 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 02 00 00 00 00 0C 00 00 00 00 04 01 00 00
Sense Key: 0x2 Not Ready, Segment 0
Sense Code: 0x04 Qual 0x01 (logical unit is in process of becoming ready) Fru 0x0
Sense flags: Blk 0 (not valid)
cmd finished after 0.006s timeout 120s
Trouble flushing the cache
Writing  time:   59.072s
Average write speed  76.4x.
Fixating...
cdrecord: Cannot fixate disk.
Fixating time:    3.021s
BURN-Free was never needed.
cdrecord: fifo had 155 puts and 92 gets.
cdrecord: fifo was 0 times empty and 20 times full, min fill was 90%.
Comment 1 Ingvar Hagelund 2006-02-20 15:35:58 EST
Just found something interesting:

Turning off DMA on the drive makes it burn without problems

# hdparm -d0 /dev/hdd

Now, what's the correct way of specifying this in /etc/sysconfig/harddisks

When this works, I have not tested with ide-scsi again. I guess that old beast
should die anyway.

Ingvar

Note You need to log in before you can comment on or make changes to this bug.