Bug 182167 - vbestate saving for Fujitsu-Siemens Amilo Pro V2000
vbestate saving for Fujitsu-Siemens Amilo Pro V2000
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pm-utils (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-20 16:05 EST by Miloslav Trmač
Modified: 2015-03-04 20:15 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-24 07:25:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miloslav Trmač 2006-02-20 16:05:48 EST
Hi,
I realize it is probably too late to add this for FC5, and it is not clear which
computers need it (all Intel graphics? probably not), anyway...

For FSC Amilo Pro V2000 suspend to RAM I need the following hook:
case "$1" in
        suspend)
                vbetool vbestate save > /var/run/vbestate
                ;;
        resume)
                vbetool vbestate restore < /var/run/vbestate
                ;;

This is with:
00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated
Graphics Device (rev 02) (prog-if 00 [VGA])
00:02.1 Display controller: Intel Corporation 82852/855GM Integrated Graphics
Device (rev 02)
(PCI ID 8086:3582).
Comment 1 Phil Knirsch 2006-02-24 04:42:30 EST
I've created a new functions-intel and included those in the suspend_video() and
resume_video() calls there and do this for every Intel video card now.

The next build should have this included.

Please let me know if this works as intended.

Read ya, Phil

Comment 2 Miloslav Trmač 2006-02-27 23:19:21 EST
Thanks, pm-utils-0.10-1 work well.

Note You need to log in before you can comment on or make changes to this bug.