Bug 182184 - kernel-2.6.15-1.1955_FC5hypervisor spontaneausly reboots
kernel-2.6.15-1.1955_FC5hypervisor spontaneausly reboots
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Juan Quintela
Brian Brock
:
Depends On:
Blocks: 179629
  Show dependency treegraph
 
Reported: 2006-02-20 16:47 EST by Bernd Bartmann
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-26 16:17:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernd Bartmann 2006-02-20 16:47:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.12) Gecko/20060202 Fedora/1.0.7-1.2.fc4 Firefox/1.0.7

Description of problem:
My system with the kernel-2.6.15-1.1955_FC5hypervisor as shipped with FC5T3 spontaneausly reboots after 10-15min. uptime. There are no messages in /var/log/messages or on the console. The system just reboots.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. install FC5T3 with kernel-2.6.15-1.1955_FC5hypervisor
2. wait for the system to reboot itself
3.
  

Additional info:
Comment 1 Bernd Bartmann 2006-02-25 15:27:09 EST
Today the system did not reboot yet, but I'm seeing messages on the console (but
not in /var/log/messages):

(XEN) APIC error on CPU0: 02(02)
(XEN) APIC error on CPU0: 02(40)
(XEN) APIC error on CPU0: 40(02)
(XEN) APIC error on CPU0: 02(02)
(XEN) APIC error on CPU0: 02(08)
(XEN) APIC error on CPU0: 08(02)
(XEN) APIC error on CPU0: 02(04)
(XEN) APIC error on CPU0: 04(02)
Comment 2 Russell Strong 2006-02-25 21:58:28 EST
I'm seeing a slight variation on this.  Same kernel. When ever I boot with the
FC5test3 DVD in the drive ( note: not the boot device ) the machine gets to
"Setting Hostname" and spontaneously reboots.
Comment 3 Ken Tanzer 2006-03-15 02:24:21 EST
When I boot the xen kernel it gets slightly into the boot process, and then
reboots.  I had this problem with xen0_1955, and still with 2041.  I've got a
Pentium D.

Here's some messages from the boot.  Apologize for paraphrasing, but it scrolls
by quickly and reboots.  Can provide any more info requested.  Thanks.

Cannot bind irq 2 to guest: in use (by?) cascade
(this line repeats twice, I think)

I do see a "red hat nash" message, along with reading or loading physical
volumes.  Then:

failed to create /dev/ram (or ram0?): file exists
failed to create /dev/ram1

There might be a couple of lines after that, and then a reboot.

My machine happily runs (non-xen) 1955_FC5smp.
Comment 4 Stephen Tweedie 2006-03-15 17:01:39 EST
Could you please try to capture a serial console output from this?  Add

  com1=38400,8n1 sync_console

to the kernel=xen... line in /etc/grub.conf (assuming 38400 baud output), and

  console=ttyS0 console=tty

to the module=vmlinuz... line.  Failing that, you may be able to capture more
console output by adding "noreboot" to the kernel=xen... line.
Comment 5 Ken Tanzer 2006-03-18 18:20:49 EST
Sorry I didn't see this sooner--forgot to CC.  Even worse, finally threw out all
my old cables a few weeks ago, so I can't capture serial output.  Might be able
to do so on Monday.

I did try "noreboot", and there is a whole bunch of error stuff that looks like
kernel panic output.  Most of it still scrolled off the screen, and what was
still there looked mostly related to reboot, so I didn't write it all down.  The
first line still visible reads:

[<c010fe0c>] smp_call_function+0x69/0x110

I did notice that after the crash the light on my DVD-ROM drive was staying on,
so I removed the disk in there and rebooted.  At this point, the boot was
successful, and I was brought to a normal graphical login.  I switched to a text
login, logged in as root, verified the xen0 kernel was running, and rebooted.

I next tried various combinations, but the results mostly confused me.  One time
when I booted without the disk, I tried the graphical login (as a normal user),
and it got 25% of the way through the Fedora/KDE initialization, and then froze.
 When I put the DVD back in my other drive (DVD burner), it booted the entire
kernel, but crashed somewhere during the rest of the startup process.  Without
the disk in, I got a couple of crashes, and a couple of successful boots.

At this moment, I am running the xen kernel (2.6.15-1.2041_FC5xen0), and was
able to login.

Sorry this is not all more precise.  I'll try to get a hold of a serial cable,
and let me know what other info would be useful in the meantime.
Comment 7 Brian Stein 2006-10-26 16:17:38 EDT
Please re-open if this issue continues.

Note You need to log in before you can comment on or make changes to this bug.