Bug 182189 - lspci missing Sil 3124 on kernel-2.6.15-1.1830_FC4
lspci missing Sil 3124 on kernel-2.6.15-1.1830_FC4
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-20 17:22 EST by Dennison Williams
Modified: 2015-01-04 17:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-08 19:30:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of lspci on both kernels (5.42 KB, text/plain)
2006-02-20 17:22 EST, Dennison Williams
no flags Details
dmesg output on 2.6.11-1.1369_FC4smp (working) (15.75 KB, text/plain)
2006-02-20 19:42 EST, Dennison Williams
no flags Details
dmesg output on 2.6.15-1.1831_FC4 (not working) (16.07 KB, text/plain)
2006-02-20 19:44 EST, Dennison Williams
no flags Details

  None (edit)
Description Dennison Williams 2006-02-20 17:22:14 EST
Description of problem:
After upgrading to the most recent FC4 kernel (2.6.15-1.1830_FC4) I am unable to
see all my SATA Raid device (Silicon Image, Inc. SiI 3124 PCI-X Serial ATA
Controller).  This showed up corectly in 2.6.11-1.1369_FC4smp.  The lspci entry
for the device in 2.6.11-1.1369_FC4smp is:

Version-Release number of selected component (if applicable):
2.6.15-1.1830_FC4

How reproducible:
upgrade kernel (2.6.15-1.1830_FC4) with yum
lsof

Steps to Reproduce:
1.upgrade kernel (2.6.15-1.1830_FC4) with yum
2.lsof
3.compare output to 2.6.11-1.1369_FC4smp

Expected results:
the output should be the same

Additional info:
it should be noted that I tried this on a standard 2.6.15.4 kernel and the
results were the same.  I am willing to do more testing, or provide more
information if needed.

motherboard: Tyan Thunder K8WE S2895

device type: (Note this is the device that is missing from the list) Addonics
Technologies ADA3GX4R (Serial ATARaid PCI/PCI-X Controller Card), Chip set:
Silicon Imagae Sil3124

/etc/modules.conf:
alias eth0 forcedeth
alias eth1 forcedeth
alias scsi_hostadapter sata_nv
alias scsi_hostadapter sata_sil24
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
options snd-intel8x0 index=0
remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-intel8x0
alias usb-controller ehci-hcd
alias usb-controller1 ohci-hcd
alias ieee1394-controller ohci1394
Comment 1 Dennison Williams 2006-02-20 17:22:15 EST
Created attachment 124915 [details]
output of lspci on both kernels
Comment 2 Dennison Williams 2006-02-20 19:15:16 EST
Please also not that I tried kernel-2.6.15-1.1831_FC4 and got the same results.
 It apears my whole PCI-X Bridge is missing from the kernel.
Comment 3 Dennison Williams 2006-02-20 19:42:59 EST
Created attachment 124922 [details]
dmesg output on 2.6.11-1.1369_FC4smp (working)
Comment 4 Dennison Williams 2006-02-20 19:44:29 EST
Created attachment 124923 [details]
dmesg output on 2.6.15-1.1831_FC4 (not working)
Comment 5 Dennison Williams 2006-04-08 19:28:48 EDT
PLease note that this "bug" was fixed by specifying Linux as my OS in my bios. 
This issue does not show itself untill kernel version 2.6.14.  I am speculating
that this has somthing to do with the following commit as noted in the <a
href="http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.14">changelog</a>:

<p>

commit 399de50bbbb2501a6db43daaa8a2dafbc9bcfe0c
Author: Michael Chan <mchan@broadcom.com>
Date:   Mon Oct 3 14:02:39 2005 -0700

    [TG3]: Refine AMD K8 write-reorder chipset test.
    
    Test for VIA K8T800 north bridge instead of AMD K8 HyperTransport
    bridge based on new information from Andi Kleen. The AMD
    HyperTransport interface is not responsible for PCI transactions
    and so the re-ordering is more likely done by the VIA north bridge.
    This code is subject to change if we get more information from AMD
    or VIA.
    
    PCI Express devices are excluded from doing the read flush since all
    chipsets in the write_reorder list are PCI chipsets.
    
    Signed-off-by: Michael Chan <mchan@broadcom.com>
    Signed-off-by: David S. Miller <davem@davemloft.net>

Note You need to log in before you can comment on or make changes to this bug.