This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 182219 - misc updates for setarch (mips/sparc32/linux64/error msg tweak)
misc updates for setarch (mips/sparc32/linux64/error msg tweak)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: setarch (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-20 22:37 EST by Mike Frysinger
Modified: 2013-07-02 19:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 09:36:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
setarch-1.8-mips.patch (445 bytes, patch)
2006-02-20 22:38 EST, Mike Frysinger
no flags Details | Diff
setarch-1.8-sparc.patch (250 bytes, patch)
2006-02-20 22:38 EST, Mike Frysinger
no flags Details | Diff
setarch-1.8-better-error.patch (276 bytes, patch)
2006-02-20 22:39 EST, Mike Frysinger
no flags Details | Diff
setarch-1.8-help.patch (1.04 KB, patch)
2006-02-21 00:27 EST, Mike Frysinger
no flags Details | Diff

  None (edit)
Description Mike Frysinger 2006-02-20 22:37:14 EST
just a bunch of small misc patches ...

setarch-1.8-mips.patch - adds support for "mips", "mips32", and "mips64" ...
also, i stuck in an alias for "linux64" alongside "linux32"

setarch-1.8-sparc.patch - adds a "sparc32" alias

setarch-1.8-better-error.patch - tweaks the error message when checking the
uname() output ... the "Don't know how to set arch to" message is already
utilized elsewhere, so having duplicate error messages is confusing when trying
to figure out where the problem lies ...
Comment 1 Mike Frysinger 2006-02-20 22:38:22 EST
Created attachment 124933 [details]
setarch-1.8-mips.patch
Comment 2 Mike Frysinger 2006-02-20 22:38:45 EST
Created attachment 124934 [details]
setarch-1.8-sparc.patch
Comment 3 Mike Frysinger 2006-02-20 22:39:19 EST
Created attachment 124935 [details]
setarch-1.8-better-error.patch
Comment 4 Mike Frysinger 2006-02-21 00:27:03 EST
Created attachment 124937 [details]
setarch-1.8-help.patch

add support for a usage/help screen and a -h help flag
Comment 5 Jindrich Novy 2006-02-21 09:36:13 EST
Some parts of your patches were applied in setarch-1.9. I'm not sure if
setarch-1.9 will occur in FC5, but if not I'll release FC5 update soon.

The mips/sparc support needed fixes also in the spec file. Adding sparc32 needed
to be connected with sparc32 utility obsoletion. I haven't applied "better-error
patch" since the original message fits more the situation that setarch is
clueless to set the desired arch. I liked the idea of linux64, so it's now
added. The bad way is that you've smuggled it in the mips patch ;-) I also
modified the "help" patch a bit and the applied.

Note You need to log in before you can comment on or make changes to this bug.