Bug 182293 - wv2: libwv2.so.1, unresolved symbols
wv2: libwv2.so.1, unresolved symbols
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: wv2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-21 12:40 EST by Rex Dieter
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 16:53:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
wv2-0.2.2-no-undefined.patch (429 bytes, patch)
2006-02-21 13:02 EST, Rex Dieter
no flags Details | Diff
specfile patch (870 bytes, patch)
2006-02-21 13:05 EST, Rex Dieter
no flags Details | Diff

  None (edit)
Description Rex Dieter 2006-02-21 12:40:59 EST
I'm guessing it needs to be linked against libstdc++ (I'll verify that in a minute):

$ldd -r /usr/lib/libwv2.so.1
        libgsf-1.so.1 => /usr/lib/libgsf-1.so.1 (0x00f76000)
        libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0x006e3000)
        libxml2.so.2 => /usr/lib/libxml2.so.2 (0x00111000)
        libpthread.so.0 => /lib/tls/libpthread.so.0 (0x00900000)
        libz.so.1 => /usr/lib/libz.so.1 (0x00206000)
        libm.so.6 => /lib/tls/libm.so.6 (0x00c22000)
        libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x0041e000)
        libc.so.6 => /lib/tls/libc.so.6 (0x00216000)
        libbz2.so.1 => /usr/lib/libbz2.so.1 (0x007f2000)
        /lib/ld-linux.so.2 (0x00d0e000)
undefined symbol: _ZSt4cerr     (/usr/lib/libwv2.so.1)
undefined symbol: _ZNSs4_Rep20_S_empty_rep_storageE     (/usr/lib/libwv2.so.1)
undefined symbol: _ZNSs4_Rep11_S_max_sizeE      (/usr/lib/libwv2.so.1)
undefined symbol: _ZSt7nothrow  (/usr/lib/libwv2.so.1)
undefined symbol: _ZSt4endlIcSt11char_traitsIcEERSt13basic_ostreamIT_T0_ES6_   
(/usr/lib/libwv2.so.1)
undefined symbol: __cxa_pure_virtual    (/usr/lib/libwv2.so.1)
undefined symbol: _ZTVN10__cxxabiv117__class_type_infoE (/usr/lib/libwv2.so.1)
undefined symbol: _ZTVN10__cxxabiv120__si_class_type_infoE     
(/usr/lib/libwv2.so.1)
undefined symbol: _Znaj (/usr/lib/libwv2.so.1)
undefined symbol: _ZStlsISt11char_traitsIcEERSt13basic_ostreamIcT_ES5_PKc      
(/usr/lib/libwv2.so.1)
undefined symbol: _ZN9__gnu_cxx18__exchange_and_addEPVii       
(/usr/lib/libwv2.so.1)
undefined symbol: _ZNKSs7compareEPKc    (/usr/lib/libwv2.so.1)
undefined symbol: _ZNSsC1ERKSs  (/usr/lib/libwv2.so.1)
undefined symbol: _ZNSolsEm     (/usr/lib/libwv2.so.1)
undefined symbol: _ZNSs6assignERKSs     (/usr/lib/libwv2.so.1)
undefined symbol: _ZNSsD1Ev     (/usr/lib/libwv2.so.1)
undefined symbol: _ZdlPv        (/usr/lib/libwv2.so.1)
undefined symbol: _ZSt20__throw_length_errorPKc (/usr/lib/libwv2.so.1)
undefined symbol: _ZNSs7reserveEj       (/usr/lib/libwv2.so.1)
undefined symbol: _ZNSt15_List_node_base6unhookEv       (/usr/lib/libwv2.so.1)
undefined symbol: _ZNSt15_List_node_base4hookEPS_       (/usr/lib/libwv2.so.1)
undefined symbol: _ZNSs9_M_mutateEjjj   (/usr/lib/libwv2.so.1)
undefined symbol: _ZNSt8ios_base4InitC1Ev       (/usr/lib/libwv2.so.1)
undefined symbol: _ZdaPv        (/usr/lib/libwv2.so.1)
undefined symbol: _ZNSs6appendERKSs     (/usr/lib/libwv2.so.1)
undefined symbol: _ZNSsC1EPKcRKSaIcE    (/usr/lib/libwv2.so.1)
undefined symbol: _ZNSsC1ERKSsjj        (/usr/lib/libwv2.so.1)
undefined symbol: _ZNSt8ios_base4InitD1Ev       (/usr/lib/libwv2.so.1)
undefined symbol: _Znwj (/usr/lib/libwv2.so.1)
undefined symbol: _ZdlPvRKSt9nothrow_t  (/usr/lib/libwv2.so.1)
undefined symbol: _ZSt20__throw_out_of_rangePKc (/usr/lib/libwv2.so.1)
undefined symbol: _ZnwjRKSt9nothrow_t   (/usr/lib/libwv2.so.1)
undefined symbol: _ZNKSs4findEcj        (/usr/lib/libwv2.so.1)
undefined symbol: _ZNSs4_Rep10_M_destroyERKSaIcE        (/usr/lib/libwv2.so.1)
undefined symbol: _ZNSs6appendEPKcj     (/usr/lib/libwv2.so.1)
Comment 1 Rex Dieter 2006-02-21 12:48:51 EST
Looks like libtool ickiness... it *should* have included -lstdc++ already
because it used g++:
/bin/sh ../libtool --mode=link g++ ...

I'll keep looking.
Comment 2 Rex Dieter 2006-02-21 13:02:11 EST
Created attachment 124974 [details]
wv2-0.2.2-no-undefined.patch
Comment 3 Rex Dieter 2006-02-21 13:05:34 EST
Created attachment 124975 [details]
specfile patch
Comment 4 Andreas Bierfert 2006-02-21 16:53:06 EST
Thanks for reporting :) Fix and build.

Note You need to log in before you can comment on or make changes to this bug.