Bug 182313 - jabberd's init script regressed from 4051 to 406
Summary: jabberd's init script regressed from 4051 to 406
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other   
(Show other bugs)
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John Wregglesworth
QA Contact: Clifford Perry
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 178198
TreeView+ depends on / blocked
 
Reported: 2006-02-21 19:43 UTC by John Wregglesworth
Modified: 2007-10-24 02:42 UTC (History)
1 user (show)

Fixed In Version: rhn406
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-15 19:01:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Wregglesworth 2006-02-21 19:43:50 UTC
Description of problem: The change I added to jabberd's init script to make it
delete files when jabberd starts didn't make it into 406.

Comment 1 John Wregglesworth 2006-02-21 19:54:38 UTC
Fixed in SVN.

Test Plan is the same as it was for bug# 179497.

Fixed in svn.

The berkeley database used by jabberd doesn't seem to like to work after jabberd
is reinstalled, so it needs to be removed when jabberd is started up. The db
doesn't contain any stateful information needed by osa-dispatcher or osad, so
the best solution seems to be to remove the files in /var/lib/jabberd/ every
time jabberd is started.

Test Plan:
1. Install a 4.0.6 sat and make sure osa-dispatcher and jabberd are up and running.

2. Install osad on a client. Make sure osad is communicating fine by pinging it
via the link in the webui on the client's Details page and seeing that it responds.

3. Upgrade jabberd to the new version and restart jabberd.

4. Repeat 2 (reinstalling osad shouldn't be necessary).

5. ls /var/lib/jabberd/ and note the files that are present.

6. Restart jabberd and make sure that the files from step 5 got deleted. You may
have to depend on the last-modified dates on the files because jabberd will
immediately replace some of them when it starts back up.



Comment 3 Todd Warner 2006-03-15 19:01:37 UTC
Closing upon release of RHN 406


Note You need to log in before you can comment on or make changes to this bug.