Bug 182336 - won't format disk if old lvm metadata is there
won't format disk if old lvm metadata is there
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-21 16:49 EST by Bill Nottingham
Modified: 2014-03-16 22:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-18 15:55:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2006-02-21 16:49:29 EST
Have, in kickstart:

part / --onpart=hda2 --fstype=ext3
part /boot --onpart=hda1 --fstype=ext3

hda2 was, at some point previous, a PV. lvm pvscan finds it.

anaconda dies trying to format hda2 with:

mke2fs 1.38 (30-Jun-2005)
/tmp/hda2 is apparently in use by the system; will not make a filesystem here!

Are we not freeing the vg we find?
Comment 1 Jeremy Katz 2006-02-22 16:17:42 EST
Can you get /tmp/lvmout?  We haven't changed any of this code, so it should be
getting removed unless lvm broke something (... surely not! :-)
Comment 2 Bill Nottingham 2006-02-22 17:02:58 EST
The box has been reinstalled about 5 times since then. Ugh. Will attempt to
reproduce.
Comment 4 Red Hat Bugzilla 2007-06-11 23:04:15 EDT
requested by Jams Antill
Comment 5 Bill Nottingham 2007-09-18 15:55:58 EDT
Closing for now. Don't have a harness to reproduce.

Note You need to log in before you can comment on or make changes to this bug.