Bug 182360 - Crash when right-clicking on package group in pirut
Crash when right-clicking on package group in pirut
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 182349 184373 185173 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-21 19:38 EST by hwQQUo
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-22 16:07:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hwQQUo 2006-02-21 19:38:38 EST
Description of problem:


Version-Release number of selected component (if applicable):
0.9.10-1.noarch

How reproducible:


Steps to Reproduce:
1. Applications > Add/Remove Software
2. Right-click on a package group (e.g. GNOME Desktop Environment)
3.
  
Actual results:


Expected results:


Additional info:

Component: Software Manager
Summary: TBf5bc6e9a GroupSelector.py:449:__doGroupPopup:OverflowError: can't
convert negative value to unsigned long

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/pirut/GroupSelector.py", line 461, in
_groupListButtonPress
    self.__doGroupPopup(event.button, long(event.time))
  File "/usr/lib/python2.4/site-packages/pirut/GroupSelector.py", line 449, in
__doGroupPopup
    menu.popup(None, None, None, button, time)
OverflowError: can't convert negative value to unsigned long

Local variables in innermost frame:
menu: <gtk.Menu object (GtkMenu) at 0xb6a07e3c>
button: 3
self: <pirut.GroupSelector.GroupSelector instance at 0xb799a9ec>
time: -1894915664
Comment 1 Jeremy Katz 2006-02-22 00:39:46 EST
*** Bug 182349 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Katz 2006-02-22 00:50:39 EST
Ugh, it looks like this is happening because of a pygtk bug in how it handles
event times.  I'll look into a fix tomorrow.
Comment 3 Jeremy Katz 2006-02-22 16:07:18 EST
Fixed in pirut
Comment 4 Jeremy Katz 2006-03-09 12:26:31 EST
*** Bug 184373 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2006-03-11 00:06:29 EST
*** Bug 185173 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.